Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 239268 - sample
sample
Status: VERIFIED WORKSFORME
Product: javafx
Classification: Unclassified
Component: Project
7.4
PC Windows 7
: P3 (vote)
: 8.0
Assigned To: Roman Svitanic
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-09 14:10 UTC by shlomob
Modified: 2013-12-20 07:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shlomob 2013-12-09 14:10:27 UTC
Itry to build one of the sample programs 
and I got this error

I copyed all the sample folder to Eclipse and its run OK

the error is:

ant -f \\\\stldrfs\\shlomob$\\NetBeansProjects\\BrickBreaker jfxsa-run
init:
Deleting: \\stldrfs\shlomob$\NetBeansProjects\BrickBreaker\build\built-jar.properties
deps-jar:
Updating property file: \\stldrfs\shlomob$\NetBeansProjects\BrickBreaker\build\built-jar.properties
compile:
Detected JavaFX Ant API version 1.2
jfx-deployment:
jar:
Copying 12 files to \\stldrfs\shlomob$\NetBeansProjects\BrickBreaker\dist\run1470264295
jfx-project-run:
Executing \\stldrfs\shlomob$\NetBeansProjects\BrickBreaker\dist\run1470264295\BrickBreaker.jar using platform C:\Program Files\Java\jdk1.7.0_45\jre/bin/java
java.io.FileNotFoundException: \\stldrfs\shlomob$\NetBeansProjects\BrickBreaker\shlomob$\NetBeansProjects\BrickBreaker\dist\run1470264295\BrickBreaker.jar (The system cannot find the path specified)
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:215)
	at java.util.zip.ZipFile.<init>(ZipFile.java:145)
	at java.util.jar.JarFile.<init>(JarFile.java:153)
	at java.util.jar.JarFile.<init>(JarFile.java:90)
	at com.javafx.main.Main.getJarAttributes(Main.java:447)
	at com.javafx.main.Main.main(Main.java:829)
Java Result: 1
Deleting directory \\stldrfs\shlomob$\NetBeansProjects\BrickBreaker\dist\run1470264295
Comment 1 Lou Dasaro 2013-12-10 05:27:00 UTC
Please make sure you've unzipped the entire project to disk, and that you've updated NetBeans 7.4 to patch1. If afterwards you're still having errors, please comment again with the info from Help->About similar to that at the bottom of this comment.

I am unable to duplicate the reported anomaly. However, you may run into Bug 236120 , (see commment 11 for that workaround)

Successfully built (skipping MSI and EXE bundlers) and ran "BrickBreaker" project copied from from javafx_samples-2_2_45-windows.zip using:

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Updates: NetBeans IDE is updated to version NetBeans 7.4 Patch 1
Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)
Comment 2 Roman Svitanic 2013-12-10 12:02:19 UTC
I'm also not able to reproduce the problem. Closing since it works for me.
Please have a look on issue mentioned by Lou. Otherwise there are no other known problems with samples.

And please check whether your permissions for specified directory (\\stldrfs\shlomob$\NetBeansProjects\BrickBreaker) are enough.

Thanks!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo