Bug 238942 - Incorrect Error Reporting for Javascript 1.7 keywords
Incorrect Error Reporting for Javascript 1.7 keywords
Status: RESOLVED DUPLICATE of bug 242387
Product: javascript
Classification: Unclassified
Component: Editor
7.4
PC Windows 8 x64
: P3 with 6 votes (vote)
: 8.0
Assigned To: Petr Hejl
issues@javascript
:
: 226477 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-28 16:20 UTC by aladio
Modified: 2016-07-18 11:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Incorrect Keyword Errors (45.55 KB, image/png)
2013-11-28 16:20 UTC, aladio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aladio 2013-11-28 16:20:12 UTC
Created attachment 142694 [details]
Incorrect Keyword Errors

Keywords let and const and maybe more keywords are reported as errors.
Reproducible on NetBeans 7.4, Window 7 x64 as well.
Comment 1 Petr Pisl 2013-12-04 13:43:18 UTC
I know about this. This is problem with Nashorn, that parse the js file and reports these errors. IMHO we can only now suppress these errors in NetBeans(don't show them), but the problem is that the file will not be parsed anyway. 

I will try to contact people from Nashorn and talk with them about this.
Comment 2 Roman Svitanic 2015-06-22 13:49:21 UTC
*** Bug 226477 has been marked as a duplicate of this bug. ***
Comment 3 JoelMac 2015-09-30 15:35:58 UTC
Also needed is the ability to recognize other syntax additions like the fat arrow functions (https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Functions/Arrow_functions).  I'm sure there's others as well. 

I'm making Chrome packaged apps.  It's a good environment to play with advanced javaScript features, because I don't need to worry about other browsers, but I can't do it in netbeans, because the files won't parse; I've got errors everywhere and some other features won't work without a cleanly parsed file.

I'm not sure if simply ignoring these errors in netbeans would work.  It needs to be aware of these JS features so that other netbeans features will work.  If I define a variable with const, the parser needs to know that I've defined a variable so that it can do the proper highlighting when it's selected.  It should also warn me if I try to assign a new value to it.

Is there a way to get a hold of the Nashorn people?  Had a hard time finding a way to contact them.  Is that project still active?
Comment 4 Petr Hejl 2016-07-18 11:25:33 UTC
This ia already working in the dev build.

*** This bug has been marked as a duplicate of bug 242387 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo