Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 238857 - error: package org.openide.util does not exist
error: package org.openide.util does not exist
Status: RESOLVED DUPLICATE of bug 196497
Product: guibuilder
Classification: Unclassified
Component: Code
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-27 08:43 UTC by tingJava2013
Modified: 2013-11-27 13:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tingJava2013 2013-11-27 08:43:27 UTC
I create NetBeans Modules, then JFrame, then JTabbedPane, then add JPanel, the code generated has this line: aJTabbedPane.addTab(org.openide.util.NbBundle.getMessage(etc..); triggering compile error of package org.openide.util does not exist.

However, skipping the creation of NetBeans Modules and going to Java Class directly, the code generated has this line: aTabbedPane.addTab("title", aJPanel); which compiles ok.

I have not touched Ant.
Comment 1 Tomas Pavek 2013-11-27 13:48:40 UTC
In NetBeans modules the GUI builder expects that org.openide.util is available. It's quite unusual a real module would not have this dependency. Bug 196497 is about that the GUI builder should add the dependency automatically. For now you need to add it manually. So go to project properties, libraries, and add org.openide.util and also org.openide.util.lookup.

You can also turn off the automatic internationalization of the GUI form if you don't want it at all (see properties of the root node in Navigator - for opened form).

*** This bug has been marked as a duplicate of bug 196497 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo