Bug 238833 - StackOverflowError at com.sun.tools.javac.util.Log.shouldReport
StackOverflowError at com.sun.tools.javac.util.Log.shouldReport
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
8.0
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 238832 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-26 15:07 UTC by Jan Lahoda
Modified: 2016-07-07 07:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (81.04 KB, text/plain)
2013-11-26 15:07 UTC, Jan Lahoda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2013-11-26 15:07:18 UTC
Build: NetBeans IDE Dev (Build 20131112-8b949209d535)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_11-b21
OS: Linux

User Comments:
jlahoda: public class TestX {
private void test() {
Map<String, List<String>> m = new HashMap<>();

m.computeIfAbsent("a", _ -> new ArrayList<>());
}
}




Stacktrace: 
java.lang.StackOverflowError
   at com.sun.tools.javac.util.Log.shouldReport(Log.java:490)
   at com.sun.tools.javac.util.Log$DefaultDiagnosticHandler.report(Log.java:663)
   at com.sun.tools.javac.util.Log.report(Log.java:624)
   at com.sun.tools.javac.util.AbstractLog.error(AbstractLog.java:107)
   at com.sun.tools.javac.parser.JavacParser.error(JavacParser.java:4020)
   at com.sun.tools.javac.parser.JavacParser.reportSyntaxError(JavacParser.java:456)
Comment 1 Jan Lahoda 2013-11-26 15:07:21 UTC
Created attachment 142605 [details]
stacktrace
Comment 2 Jan Lahoda 2013-11-26 15:09:18 UTC
*** Bug 238832 has been marked as a duplicate of this bug. ***
Comment 3 Martin Balin 2016-07-07 07:19:06 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo