Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 238633 - Problem reading properly folder name
Problem reading properly folder name
Status: RESOLVED DUPLICATE of bug 238679
Product: php
Classification: Unclassified
Component: Project
7.4
PC Windows 7
: P3 with 1 vote (vote)
: 8.0
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 22:27 UTC by jmail
Modified: 2013-12-04 10:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
graphical bug description (200.71 KB, image/png)
2013-11-20 22:27 UTC, jmail
Details
Cake PHP lowercase dir names (123.30 KB, image/png)
2013-11-22 13:30 UTC, mmolda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmail 2013-11-20 22:27:51 UTC
Created attachment 142425 [details]
graphical bug description

NetBeans 7.4 for PHP are not reading properly folder's names.

I've got CakePHP projects (I am caker ;)) and in every project I've got folders Config and Console. This folder's names starts with capital letter. In NetBeans 7.3.1 everything is ok but in 7.4 first letter is lowercase. 

In attachement I am showing the problem. On disk it is uppercase, in NetBeans 7.3.1 also and in NetBeans 7.4 that is wrong.

I have also noticed that I can change folder name to uppercase first letter via NetBeans and it's working... until netbeans restarts - everything coming back to wrong first letter case
Comment 1 jmail 2013-11-20 22:51:55 UTC
Now I realized that maybe that is problem with CakePHP plugin? After installing cakePHP plugin into beans 7.3.1 that is the same problem but only with Config folder.
Comment 2 Tomas Mysik 2013-11-21 06:41:52 UTC
Please, test it without CaekPHP plugin (it is not official part of NetBeans) so we know where the problem is. Let us know and feel free to report a bug directly against CakePHP plugin if the problem is there.

Thanks.
Comment 3 mmolda 2013-11-22 13:29:54 UTC
Tomasi, I just tested it in dev build without any plugins and it is reproducible - see screenshot. I don't really know what causes that.

> I have also noticed that I can change folder name to uppercase first letter
> via NetBeans and it's working... until netbeans restarts - everything coming
> back to wrong first letter case

this is also true.


Cake PHP version 2.4.2

Product Version: NetBeans IDE Dev (Build 201311220002)
Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 7 version 6.1 running on x86; Cp1250; en_US (nb)
Comment 4 mmolda 2013-11-22 13:30:42 UTC
Created attachment 142485 [details]
Cake PHP lowercase dir names
Comment 5 Tomas Mysik 2013-11-22 14:14:48 UTC
Milane, please, test also e.g. HTML5 project type to find out whether it is PHP specific or not.

Thanks.
Comment 6 mmolda 2013-11-22 16:05:08 UTC
It seems to be PHP specific. Using same source files, dir names begin correctly with Uppercase in HTML5 project.
Comment 7 mmolda 2013-11-22 16:12:21 UTC
It looks like some specific folder names are displayed wrong. Simple scenario is:
1. Create new PHP project
2. Create directory "app"
3. In app directory create directory "Config"
4. Restart NetBeans
5. Config is displayed with lowercase as "config"
Comment 8 mmolda 2013-11-22 16:53:43 UTC
It is also Windows specific, just tested it on Ubuntu and it works fine.

Product Version: NetBeans IDE Dev (Build 201311220002)
Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Linux version 3.5.0-17-generic running on i386; UTF-8; en_US (nb)
Comment 9 Tomas Mysik 2013-12-04 10:01:30 UTC

*** This bug has been marked as a duplicate of bug 238679 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo