Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 238460 - JavaFX is not working properly and not detected Scene Builder 2.0
JavaFX is not working properly and not detected Scene Builder 2.0
Status: VERIFIED DUPLICATE of bug 238520
Product: javafx
Classification: Unclassified
Component: Visual Tool Integration
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: David Strupl
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 15:04 UTC by ldlopez
Modified: 2013-12-28 07:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (56.15 KB, text/plain)
2013-11-16 15:04 UTC, ldlopez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ldlopez 2013-11-16 15:04:19 UTC
Product Version = NetBeans IDE 7.4 (Build 201310111528)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_45
Runtime = Java HotSpot(TM) 64-Bit Server VM 24.45-b08

NetBeans does not detect JDK JFX which is included by default in the Java version. If I see within "Java Platform" is not any of the jar to allow development in javafx. That is why in my new projects and either javafx projects destribullen in the package "javafx_samples-2_2_25-windows.zip" not detects classes that are in packages "javafx.beans.*", "javafx.collections.*", "javafs. scene.*", etc..
Also I can not tell where it is installed Scene Builder, is that this should be done from "Tools \ Options \ Java \ JavaFX" and selecting the directory where it is installed Scene Builder. I guess it must be because it is properly installed JavaFX.
Could you tell what my problem is, and how I can fix it. In the header of this report indicates the version I have installed Java and NetBeans version I am using.
Comment 1 ldlopez 2013-11-16 15:04:31 UTC
Created attachment 142266 [details]
IDE log
Comment 2 Lou Dasaro 2013-11-29 19:05:59 UTC
Sorry to hear you're having trouble. 
First, JavaFX Scene Builder 2.0 "Early Access" is not supported by NetBeans 7.4 or 7.4.1 AFAIK, current plan is to (hopefully soon) support SB 2.0 E.A. in DEV/NB 8.0 See Bug 238520 for more details.

Second, there is an existing Bug in the Sample projects that prevents them from properly building. If you cloned one of these projects, it would explain problems building them. The fix is in-progress, and is described in comment #14 of Bug 236120

Please update your installation to 7.4.1, which contains 151 fixes, including some critical fixes to Scene Builder 1.1 integration.
Comment 3 David Strupl 2013-12-02 12:16:49 UTC
Hello,

I am marking this report as duplicate of 238520. Although the other part is duplicate of 236120. Please check both reports as to when they are addressed. Thanks for the report. And also thanks to mr_lou_d@netbeans.org for the proper and prompt evaluation of this report.

David

*** This bug has been marked as a duplicate of bug 238520 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo