Bug 238037 - AssertionError: Value of x -1
AssertionError: Value of x -1
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
8.0
All All
: P2 (vote)
: Dev
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT, 80patch1-candidate
:
: 242560 242963 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 11:14 UTC by Jiri Prox
Modified: 2014-04-16 13:07 UTC (History)
14 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.98 KB, text/plain)
2013-11-06 11:14 UTC, Jiri Prox
Details
stacktrace (3.51 KB, text/plain)
2013-12-13 12:24 UTC, Milos Kleint
Details
stacktrace (4.59 KB, text/plain)
2014-01-13 15:15 UTC, J Bachorik
Details
stacktrace (7.18 KB, text/plain)
2014-01-16 13:42 UTC, Exceptions Reporter
Details
stacktrace (4.66 KB, text/plain)
2014-01-17 11:06 UTC, FrantaM
Details
stacktrace (7.02 KB, text/plain)
2014-01-22 16:24 UTC, _ tboudreau
Details
stacktrace (4.84 KB, text/plain)
2014-01-27 08:46 UTC, J Bachorik
Details
Source file that caused an exception when double-clicked (1.55 KB, text/x-java)
2014-02-24 18:25 UTC, _ tboudreau
Details
stacktrace (3.40 KB, text/plain)
2014-02-24 18:29 UTC, _ tboudreau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2013-11-06 11:14:55 UTC
Build: NetBeans IDE Dev (Build 20131029-bad6e88b3089)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b49, Java(TM) SE Runtime Environment, 1.8.0-ea-b107
OS: Windows 7

User Comments:
jiriprox: AE when trying to display parameters (ctrl-p) of constructor call. 

 public static Set<Graph> construct(int n) {
        BlockingQueue<State> fifo = new ArrayBlockingQueue<State>();
        fifo.add(new State(Graph.EMPTY_GRAPH, input.clone));

        return null;
    }




Stacktrace: 
java.lang.AssertionError: Value of x -1
   at com.sun.tools.javac.util.Assert.error(Assert.java:133)
   at com.sun.tools.javac.util.Assert.check(Assert.java:94)
   at com.sun.tools.javac.util.Bits.incl(Bits.java:186)
   at com.sun.tools.javac.comp.Flow$AbstractAssignAnalyzer.initParam(Flow.java:1824)
   at com.sun.tools.javac.jvm.Gen$LVTAssignAnalyzer.initParam(Gen.java:2854)
   at com.sun.tools.javac.comp.Flow$AbstractAssignAnalyzer.visitMethodDef(Flow.java:1778)
Comment 1 Jiri Prox 2013-11-06 11:14:59 UTC
Created attachment 141891 [details]
stacktrace
Comment 2 Milos Kleint 2013-12-13 12:24:52 UTC
Created attachment 143145 [details]
stacktrace

just having java files opened
Comment 3 J Bachorik 2014-01-13 15:15:46 UTC
Created attachment 143908 [details]
stacktrace

Opening a OpenJDK 9 JMX project
Comment 4 Exceptions Reporter 2014-01-16 13:42:47 UTC
Created attachment 144032 [details]
stacktrace

Refactor classe name
Comment 5 FrantaM 2014-01-17 11:06:48 UTC
Created attachment 144065 [details]
stacktrace

typing
Comment 6 Exceptions Reporter 2014-01-21 19:21:52 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=205068
Comment 7 _ tboudreau 2014-01-22 16:24:53 UTC
Created attachment 144256 [details]
stacktrace

Opened a project, edited a file, did not save it;  switched project group to a group which contains the project of that file;  tried to save the file while the newly opened projects in the project group were being scanned.
Comment 8 J Bachorik 2014-01-27 08:46:09 UTC
Created attachment 144395 [details]
stacktrace

Trying to create a project with existing sources for OpenJDK9 java classes
Comment 9 Alexander Simon 2014-02-21 18:24:15 UTC
26 reports => P2
Comment 10 Dusan Balek 2014-02-24 08:56:57 UTC
Hard to fix without a reproducible test case. If you are able to reproduce it, create a simple test case and attach it to the issue. Thanks.
Comment 11 _ tboudreau 2014-02-24 18:25:35 UTC
Created attachment 145545 [details]
Source file that caused an exception when double-clicked

FWIW, this is the source file I double-clicked for the most recent exception report.

I'd suspect some kind of race-condition between parsing the file and trying to generate hints, etc.
Comment 12 _ tboudreau 2014-02-24 18:29:04 UTC
Created attachment 145546 [details]
stacktrace

Double clicked to open a Java source
Comment 13 Dusan Balek 2014-02-26 15:11:29 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/cd67dc87ca96
Comment 14 Quality Engineering 2014-03-01 06:14:13 UTC
Integrated into 'main-silver', will be available in build *201403010001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/cd67dc87ca96
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #238037: AssertionError: Value of x -1 - fixed.
Comment 15 Jiri Prox 2014-03-05 07:03:28 UTC
*** Bug 242560 has been marked as a duplicate of this bug. ***
Comment 16 Dusan Balek 2014-03-21 09:23:18 UTC
*** Bug 242963 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo