Bug 237892 - Invalid line index=1205 >= lineCount=1047
Invalid line index=1205 >= lineCount=1047
Status: RESOLVED DUPLICATE of bug 236147
Product: platform
Classification: Unclassified
Component: Text
7.4
PC Windows XP
: P1 (vote)
: TBD
Assigned To: frfr.rmcan
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 14:19 UTC by frfr.rmcan
Modified: 2013-11-13 12:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.34 KB, text/plain)
2013-11-01 14:24 UTC, frfr.rmcan
Details
verbose output (5.52 KB, text/plain)
2013-11-01 14:25 UTC, frfr.rmcan
Details
UI log (28.52 KB, text/plain)
2013-11-01 14:36 UTC, frfr.rmcan
Details
IDE log (50.01 KB, text/plain)
2013-11-01 14:36 UTC, frfr.rmcan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description frfr.rmcan 2013-11-01 14:19:16 UTC
i'm working on a small java swing project and can't debug it for some days now. Every time i click on the "Debug Project"-Button netbeans starts the debug session an the buttons to control program flow (step over and so on) and the "variables"-view appear but disappear after about 1 second.
The Output says :"BUILD SUCCESSFUL" but i get the following notification:
"Unexpected Exception
Priority: SILENT Category: Error
Invalid line index=1205 >= lineCount=1047"
Debug worked before and i can build my project without any problems.
Comment 1 Martin Entlicher 2013-11-01 14:23:19 UTC
Can you please turn verbose output on so that we see the details about the error?
Please go to Tools -> Options, Select Java, Ant tab and change Verbosity level to Verbose. Then Debug Project again. Thanks.
Comment 2 frfr.rmcan 2013-11-01 14:24:27 UTC
Created attachment 141776 [details]
stacktrace

added stacktrace
Comment 3 frfr.rmcan 2013-11-01 14:25:45 UTC
Created attachment 141777 [details]
verbose output
Comment 4 frfr.rmcan 2013-11-01 14:27:19 UTC
(In reply to Martin Entlicher from comment #1)
> Can you please turn verbose output on so that we see the details about the
> error?
> Please go to Tools -> Options, Select Java, Ant tab and change Verbosity
> level to Verbose. Then Debug Project again. Thanks.

Thanks for the fast answer. I've added the output on verbose level
Comment 5 Martin Entlicher 2013-11-01 14:32:32 UTC
Thanks, it is an editor or openide/text problem...
But this exception does not seem to really break the debugger. Maybe there are more problems that interrupt the debugging. If you attach the messages log file, we can look if there were more exceptions associated.
Thanks, passing to the text component...
Comment 6 Martin Entlicher 2013-11-01 14:34:21 UTC
First I thought that the Unexpected Exception was in the Output tab. Since there was no error in the program itself, it's not apparent yet why the debugged finished.
Comment 7 frfr.rmcan 2013-11-01 14:36:34 UTC
Created attachment 141781 [details]
UI log
Comment 8 frfr.rmcan 2013-11-01 14:36:50 UTC
Created attachment 141782 [details]
IDE log
Comment 9 frfr.rmcan 2013-11-01 14:40:20 UTC
(In reply to Martin Entlicher from comment #6)
> First I thought that the Unexpected Exception was in the Output tab. Since
> there was no error in the program itself, it's not apparent yet why the
> debugged finished.

The output tab has two tabs in it. "<ProjectName>(debug)" and "Debugger Console"
"<ProjectName>(debug)" says(output back on normal):
"debug:
BUILD SUCCESSFUL (total time: 0 seconds)"

"Debugger Console" says(output back on normal):
"Listening on javadebug
Invalid line index=1205 >= lineCount=1047"
Comment 10 Miloslav Metelka 2013-11-13 12:55:40 UTC

*** This bug has been marked as a duplicate of bug 236147 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo