Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 23782 - Content Language property must be at least trimed
Content Language property must be at least trimed
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Code
3.x
PC Windows 95/98
: P4 (vote)
: 3.x
Assigned To: _ rkubacki
issues@javaee
:
Depends on: 29447
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 15:07 UTC by Alexei Mokeev
Modified: 2003-12-11 14:27 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexei Mokeev 2002-05-21 15:07:24 UTC
Additional handling of "Content Language" property required.
Now it just set all text from Property Editor as is.

Steps to reproduce:

1)Open Properties for some servlet
2)Press "..." button near "Content Language" property
3)Type "text/html + Enter" in property editor and press OK
NOTICE, that valid value "text/html" in shown near "Content Language" property
4)Try execute servlet and notice, that browser don't started and Warning window
with message "There is no browser configured for MIME type "text/html
."

Think that editor shouldn't allow multyline values for this property ot at least trim \r,\n from
end of string.

Well reproduced with FFJ4.0 rc4, jdk 1.4.0 under Win98SE
Comment 1 Marek Grummich 2002-07-22 11:29:30 UTC
Set target milestone to TBD
Comment 2 Marek Grummich 2002-07-22 11:31:29 UTC
Set target milestone to TBD
Comment 3 Marian Mirilovic 2002-12-06 17:08:51 UTC
reassigne to Tim, new owner of property editors.
Comment 4 _ tboudreau 2003-04-04 10:20:35 UTC
See

http://www.netbeans.org/issues/show_bug.cgi?id=29294

Whoever provides the Content Language property can now provide the
hint "oneline" to the propertyeditor - return Boolean.TRUE from
ContentLanguageProperty.getValue ("oneline") - and the string 
editor will use a JTextField, and the user cannot enter newlines.

I don't know who provides this property,
but since the example is from a Servlet, 
I'm reassigning to Web module. 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo