Bug 237594 - Embedded browser crashes IDE
Embedded browser crashes IDE
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
PC Linux
: P3 (vote)
: 8.0
Assigned To: Stanislav Aubrecht
issues@platform
https://javafx-jira.kenai.com/browse/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 00:15 UTC by adithyank
Modified: 2013-11-27 13:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log of crashed netbeans session (205.24 KB, text/plain)
2013-10-24 12:14 UTC, adithyank
Details
netbeans... messages.log of this crashed netbeans session (156.38 KB, text/plain)
2013-10-24 18:40 UTC, adithyank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adithyank 2013-10-24 00:15:01 UTC
Product Version = NetBeans IDE 7.4 (Build 201310111528)
Operating System = Linux version 2.6.32-358.23.2.el6.i686 running on i386
Java; VM; Vendor = 1.7.0_40
Runtime = Java HotSpot(TM) Client VM 24.0-b56

The IDE crashes when I perform the following steps. I am able to consistently reproduce this with the same sequence of steps

1. Create a new HTML5 -> HTML5 Application (next button)
2. Give some name. I gave TestHTML5Application (next button)
3. Leave the selection as "No Site template". (next button)
4. Leave default path. No lib selection (finish button)
5. Now project is created in the Projects window
6. Expand the Project. TestHTML5Application -> Site root -> index.html
7. Double click the index.html
8. It has got opened in the right side editor window
9. Now click "Preview" near the source button in the editor area
10. That is it. For 15 to 20 seconds, the UI is unresponsive. Then Netbeans IDE itelf crashed. No java process is available in "ps -ef | grep java"
Comment 1 Petr Cyhelsky 2013-10-24 07:42:44 UTC
Sounds like jdk bug - there should be a hs_err_pid... file in your $Netbeans _Installation/bin directory, please attach this file along with the messages.log to this issue. Reassigning to html for further evaluation...
Comment 2 adithyank 2013-10-24 12:13:59 UTC
hs_err_pid* file is not generated in the netbeans intallation dir/bin.
Attaching messages.log.1 of the crashed netbeans session.
Comment 3 adithyank 2013-10-24 12:14:07 UTC
Created attachment 141516 [details]
messages.log of crashed netbeans session
Comment 4 Tomas Mysik 2013-10-24 12:37:36 UTC
(In reply to adithyank from comment #0)
> 9. Now click "Preview" near the source button in the editor area

There is no Preview button in the default NB installation - this is perhaps the reason, you have installed some plugin manually, right? You can uninstall it and it should work. Feel free to report this issue against that module.

Thanks.
Comment 5 Stanislav Aubrecht 2013-10-24 14:14:58 UTC
Reporter, when you switch the browser in Tools - Options to Embedded Webkit Browser can you display all HTML pages or does it crash as well?
Comment 6 adithyank 2013-10-24 18:39:14 UTC
Stanislav Aubrecht,

1. As per one of the previous comments, I deactivated that specific plugin that gave "Preview" button near the "Source" button in the editor.

2. Now, as per your advice I did set "Embedded web kit browser" as the default in Tools -> Options and also in the Project Properties -> Run screens.

3. Then I did the following steps
a. selected project node in the NB Projects window
b. Right click > select run

For some time the UI was unresponsive and it again crashed. no coredump in netbeans-installation-dir/bin.

So, again attaching the var/log/messages...
Comment 7 adithyank 2013-10-24 18:40:30 UTC
Created attachment 141532 [details]
netbeans... messages.log of this crashed netbeans session
Comment 8 Stanislav Aubrecht 2013-10-25 06:23:44 UTC
What kind of Linux distro are you running?
Comment 9 adithyank 2013-10-25 06:29:31 UTC
CentOS 6.4 (Linux Distribution derived from RedHat Enterprise Linux 6.4)

Some thing more

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Linux version 2.6.32-358.23.2.el6.i686 running on i386; UTF-8; en_US (nb)
User directory: /root/.netbeans/7.4
Cache directory: /root/.cache/netbeans/7.4
Comment 10 geversonsto 2013-10-25 13:33:40 UTC
I have the same problem in Ubuntu 13.04

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Linux version 3.8.0-19-generic running on i386; UTF-8; pt_BR (nb)
Comment 11 Stanislav Aubrecht 2013-10-25 14:12:16 UTC
(In reply to geversonsto from comment #10)
> I have the same problem in Ubuntu 13.04
> 
> Product Version: NetBeans IDE 7.4 (Build 201310111528)
> Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
> Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
> System: Linux version 3.8.0-19-generic running on i386; UTF-8; pt_BR (nb)

Any JVM crash log?
Comment 12 Stanislav Aubrecht 2013-10-25 14:44:20 UTC
It seems that JavaFX support only Ubuntu 10.4 or better, see here http://www.oracle.com/technetwork/java/javafx/downloads/supportedconfigurations-1506746.html
Comment 13 Vladimir Riha 2013-10-29 17:27:23 UTC
For what it's worth, I've tried it on Ubuntu 13.10 and cannot reproduce

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Linux version 3.11.0-12-generic running on amd64; UTF-8; en_US (nb)
Comment 14 geversonsto 2013-11-11 23:00:55 UTC
[Solved] In my case the problem was caused by the plugin "Java Ayatana" after it disables the "HTML Preview" went to work.



(In reply to Stanislav Aubrecht from comment #11)
> (In reply to geversonsto from comment #10)
> > I have the same problem in Ubuntu 13.04
> > 
> > Product Version: NetBeans IDE 7.4 (Build 201310111528)
> > Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
> > Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
> > System: Linux version 3.8.0-19-generic running on i386; UTF-8; pt_BR (nb)
> 
> Any JVM crash log?
Comment 15 Stanislav Aubrecht 2013-11-27 11:43:30 UTC
Looks like this JavaFX bug: https://javafx-jira.kenai.com/browse/RT-29939


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo