Bug 237561 - Failing tests on JDK8
Failing tests on JDK8
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
8.0
All All
: P1 (vote)
: 8.0
Assigned To: Jaroslav Tulach
issues@platform
: JDK_8, JDK_SPECIFIC, TEST
: 237854 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 14:12 UTC by Jiri Skrivanek
Modified: 2013-11-25 09:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2013-10-23 14:12:44 UTC
Please, fix tests failing on JDK8. To reproduce:

ant -f openide.util test-unit -Dtest.includes=**/ImageUtilitiesGetLoaderTest.class

http://test4u.cz.oracle.com/job/StableBTD-trunk/lastCompletedBuild/testReport
Comment 1 Jiri Skrivanek 2013-10-31 14:14:29 UTC
*** Bug 237854 has been marked as a duplicate of this bug. ***
Comment 2 Jan Peska 2013-11-19 12:49:50 UTC
Jardo, can you please take a look at this? The test was written by you and honestly I know nothing about it or ImageItilities.

Thanks
Comment 3 Jaroslav Tulach 2013-11-20 08:08:45 UTC
I don't see the test failing at the given link. Searching for "Image" no the page yields no results.

Locally on 1.8.0-ea-b113 I get following failure however:



$ ant -f openide.util/build.xml test-unit -Dtest.includes=**/ImageUtilitiesGetLoaderTest.class -Dnbjdk.home=/usr/local/lib/jdk1.8.0/

Testcase: testWrongImplOfGetLoaderIssue62194(ImageUtilitiesGetLoaderTest): FAILED
Error manager race condition activated
junit.framework.AssertionFailedError: Error manager race condition activated
at o.o.util.ImageUtilitiesGetLoaderTest.testWrongImplOfGetLoaderIssue62194(:80)
Test org.openide.util.ImageUtilitiesGetLoaderTest FAILED
Comment 4 Jaroslav Tulach 2013-11-20 09:05:15 UTC
ergonomics#cc33b393d965
Comment 5 Quality Engineering 2013-11-24 02:20:40 UTC
Integrated into 'main-silver', will be available in build *201311240002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/cc33b393d965
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #237561: Something changed in the way JDK8 initializes loggers. Need to init the AWT's logger first before changing global logger's level to ALL.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo