Please use the Apache issue tracking system for new NetBeans issues ( !!
Bug 237477 - could not start glassfish server 4 administrator port is occupied by null
could not start glassfish server 4 administrator port is occupied by null
Status: NEW
Product: serverplugins
Classification: Unclassified
Component: GlassFish
PC Windows 8.1 x64
: P3 with 3 votes (vote)
Assigned To: TomasKraus
Depends on:
  Show dependency treegraph
Reported: 2013-10-22 13:19 UTC by ajacob
Modified: 2016-06-07 09:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT

Server log (34.47 KB, application/octet-stream)
2014-01-03 15:41 UTC, ajqarshi

Note You need to log in before you can comment on or make changes to this bug.
Description ajacob 2013-10-22 13:19:37 UTC
Since I upgraded from Netbeans 7.3.1 to Netbeans 7.4 I'm getting an error I never met before.
When trying to deploy or redeploy an application I get this :

NetBeans: Deploying on GlassFish Server
    profile mode: false
    debug mode: false
    force redeploy: true
Starting GlassFish Server
Could not start GlassFish Server: Administrator port is occupied by null
Deployment error: Could not start GlassFish Server: Administrator port is occupied by null
See the server log for details.
	at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(
	at org.netbeans.modules.maven.j2ee.ExecutionChecker.performDeploy(
	at org.netbeans.modules.maven.j2ee.ExecutionChecker.executionResult(

It's happening quite often but I've not yet found the steps to follow to reproduce the problem.
What I can observe is that from Netbeans point of view Glassfish is not started (I can't stop it for example)

To get rid of the problem I have to close Netbeans and then manually close Glassfish and restart everything.

Without knowing if it is linked or not I should say that I'm often working with two different war projects deployed on the same glassfish instance. The problem can occur while deploying one of the two project (doesn't matter which one).
Comment 1 ajqarshi 2014-01-03 15:41:22 UTC
Created attachment 143582 [details]
Server log

I had similar issue. I followed following steps and now trapped:

Brand new 64 Machine running Windows 8.1 (So there shouldn't be any port conflict probably).

Installed latest JDK 1.7.0_45
Installed Glassfish 4.0 for 64-bit Windows (Final start-domain step took around 15 minutes on my fast machine).
Installed NetBeans 7.4.
Configured the NetBeans to link with the local installation of Glassfish Server.
Tried to start the server from within NetBeans and got following error message:

"Could not start GlassFish Server: DAS port is occupied while server is not running".

I've attached the server log

On subsequent tries, I get following error message:
"Could not start Glassfish Server: Administrator port is occupied by null".
Comment 2 Maksim Khramov 2014-03-31 08:26:07 UTC
I have reproduced this with such conditions:
I have already running old GF2 instance and I try to run web application on new GF4 instance.
Comment 3 kvyas 2015-01-07 05:44:41 UTC
I tried this with NB 8.0.2 in trying to get the GlassFish Server to work but to no avail:  I keep getting "Administration port is occupied by null".  I have to remove the server and x out of NB and restart NB and add GlassFish only to get the same old error above.

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo