Bug 236927 - Assert errors in ide logs
Assert errors in ide logs
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
PC Windows 8
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 09:23 UTC by mhankus
Modified: 2016-07-07 07:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
requested dump file (14.01 KB, application/octet-stream)
2013-10-09 09:23 UTC, mhankus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mhankus 2013-10-09 09:23:30 UTC
Created attachment 140932 [details]
requested dump file

My Ide log is full of Assert errors as show below ( Netbeans 7.4RC1 ), requesting to file a bug. 




ALL [null]: An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-sitemap\pl\netpr\services\sitemap\xml\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc1\var\log\package-info_24.dump'.
INFO [org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch]: Exception while performing batch processing in C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-sitemap\pl\netpr\services\sitemap\xml\package-info.java
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-sitemap\pl\netpr\services\sitemap\xml\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc1\var\log\package-info_24.dump'.
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-sitemap\pl\netpr\services\sitemap\xml\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc1\var\log\package-info_24.dump'.
Caused: java.lang.AssertionError
	at com.sun.tools.javac.util.Assert.error(Assert.java:126)
	at com.sun.tools.javac.util.Assert.check(Assert.java:45)
	at com.sun.tools.javac.code.Annotations.setDeclarationAttributesWithCompletion(Annotations.java:161)
	at com.sun.tools.javac.code.Symbol.setDeclarationAttributesWithCompletion(Symbol.java:217)
	at com.sun.tools.javac.comp.MemberEnter.actualEnterAnnotations(MemberEnter.java:1093)
	at com.sun.tools.javac.comp.MemberEnter.access$400(MemberEnter.java:70)
	at com.sun.tools.javac.comp.MemberEnter$5.enterAnnotation(MemberEnter.java:1032)
	at com.sun.tools.javac.comp.Annotate.flush(Annotate.java:131)
	at com.sun.tools.javac.comp.Annotate.enterDone(Annotate.java:123)
	at com.sun.tools.javac.comp.Enter.complete(Enter.java:747)
	at com.sun.tools.javac.main.JavaCompiler.complete(JavaCompiler.java:1036)
	at com.sun.tools.javac.main.JavaCompiler.enterTrees(JavaCompiler.java:998)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:370)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:310)
	at org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:653)
	at org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:385)
	at org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:109)
[catch] at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$3.run(BatchSearch.java:272)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$3.run(BatchSearch.java:264)
	at org.netbeans.api.java.source.JavaSource$MultiTask.run(JavaSource.java:493)
	at org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:593)
	at org.netbeans.modules.parsing.api.ParserManager$MultiUserTaskAction.run(ParserManager.java:191)
	at org.netbeans.modules.parsing.api.ParserManager$MultiUserTaskAction.run(ParserManager.java:163)
	at org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:206)
	at org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:203)
	at org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:176)
	at org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:360)
	at org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:74)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:203)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:108)
	at org.netbeans.api.java.source.JavaSource.runUserActionTaskImpl(JavaSource.java:443)
	at org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:414)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getLocalVerifiedSpans(BatchSearch.java:264)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.access$600(BatchSearch.java:99)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$LocalIndexEnquirer.validateResource(BatchSearch.java:574)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getVerifiedSpans(BatchSearch.java:207)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getVerifiedSpans(BatchSearch.java:189)
	at org.netbeans.modules.java.hints.analysis.AnalyzerImpl.analyze(AnalyzerImpl.java:130)
	at org.netbeans.modules.analysis.RunAnalysis$1$1.doRunAnalyzer(RunAnalysis.java:209)
	at org.netbeans.modules.analysis.RunAnalysis$1$1.run(RunAnalysis.java:161)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2042)
Comment 1 Svata Dedic 2013-10-10 11:49:59 UTC
Cannot reproduce in dev version. But normal java file is being processed from a FileObject -> compiler issue ? Please evaluate
Comment 2 mhankus 2013-10-10 22:54:59 UTC
I've installed 7.4RC2. It was working fine, but when I started Source->Inspect and selected all available inspection engines, exceptions returned and after few minutes OutOfMemory occured (look below)

An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-notoria-stat\pl\netpr\services\stock\stat\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_3.dump'.
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-notoria-stat\pl\netpr\services\stock\stat\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_3.dump'.
Caused: java.lang.AssertionError
	at com.sun.tools.javac.util.Assert.error(Assert.java:126)
	at com.sun.tools.javac.util.Assert.check(Assert.java:45)
	at com.sun.tools.javac.code.Annotations.setDeclarationAttributesWithCompletion(Annotations.java:161)
	at com.sun.tools.javac.code.Symbol.setDeclarationAttributesWithCompletion(Symbol.java:217)
	at com.sun.tools.javac.comp.MemberEnter.actualEnterAnnotations(MemberEnter.java:1093)
	at com.sun.tools.javac.comp.MemberEnter.access$400(MemberEnter.java:70)
	at com.sun.tools.javac.comp.MemberEnter$5.enterAnnotation(MemberEnter.java:1032)
	at com.sun.tools.javac.comp.Annotate.flush(Annotate.java:131)
	at com.sun.tools.javac.comp.Annotate.enterDone(Annotate.java:123)
	at com.sun.tools.javac.comp.Enter.complete(Enter.java:747)
	at com.sun.tools.javac.main.JavaCompiler.complete(JavaCompiler.java:1036)
	at com.sun.tools.javac.main.JavaCompiler.enterTrees(JavaCompiler.java:998)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:370)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:310)
	at org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:653)
	at org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:385)
	at org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:109)
[catch] at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$3.run(BatchSearch.java:272)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$3.run(BatchSearch.java:264)
	at org.netbeans.api.java.source.JavaSource$MultiTask.run(JavaSource.java:493)
	at org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:593)
	at org.netbeans.modules.parsing.api.ParserManager$MultiUserTaskAction.run(ParserManager.java:191)
	at org.netbeans.modules.parsing.api.ParserManager$MultiUserTaskAction.run(ParserManager.java:163)
	at org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:206)
	at org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:203)
	at org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:176)
	at org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:360)
	at org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:74)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:203)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:108)
	at org.netbeans.api.java.source.JavaSource.runUserActionTaskImpl(JavaSource.java:443)
	at org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:414)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getLocalVerifiedSpans(BatchSearch.java:264)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.access$600(BatchSearch.java:99)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$LocalIndexEnquirer.validateResource(BatchSearch.java:574)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getVerifiedSpans(BatchSearch.java:207)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getVerifiedSpans(BatchSearch.java:189)
	at org.netbeans.modules.java.hints.analysis.AnalyzerImpl.analyze(AnalyzerImpl.java:130)
	at org.netbeans.modules.analysis.RunAnalysis$1$1.doRunAnalyzer(RunAnalysis.java:209)
	at org.netbeans.modules.analysis.RunAnalysis$1$1.run(RunAnalysis.java:161)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2042)
ALL [null]: An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-notoria-stat\pl\netpr\services\stock\stat\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_3.dump'.
SEVERE [org.openide.util.Exceptions]
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-gpw\pl\netpr\services\stock\gpw\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_4.dump'.
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-gpw\pl\netpr\services\stock\gpw\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_4.dump'.
Caused: java.lang.AssertionError
	at com.sun.tools.javac.util.Assert.error(Assert.java:126)
	at com.sun.tools.javac.util.Assert.check(Assert.java:45)
	at com.sun.tools.javac.code.Annotations.setDeclarationAttributesWithCompletion(Annotations.java:161)
	at com.sun.tools.javac.code.Symbol.setDeclarationAttributesWithCompletion(Symbol.java:217)
	at com.sun.tools.javac.comp.MemberEnter.actualEnterAnnotations(MemberEnter.java:1093)
	at com.sun.tools.javac.comp.MemberEnter.access$400(MemberEnter.java:70)
	at com.sun.tools.javac.comp.MemberEnter$5.enterAnnotation(MemberEnter.java:1032)
	at com.sun.tools.javac.comp.Annotate.flush(Annotate.java:131)
	at com.sun.tools.javac.comp.Annotate.enterDone(Annotate.java:123)
	at com.sun.tools.javac.comp.Enter.complete(Enter.java:747)
	at com.sun.tools.javac.main.JavaCompiler.complete(JavaCompiler.java:1036)
	at com.sun.tools.javac.main.JavaCompiler.enterTrees(JavaCompiler.java:998)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:370)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:310)
	at org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:653)
	at org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:385)
	at org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:109)
[catch] at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$3.run(BatchSearch.java:272)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$3.run(BatchSearch.java:264)
	at org.netbeans.api.java.source.JavaSource$MultiTask.run(JavaSource.java:493)
	at org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:593)
	at org.netbeans.modules.parsing.api.ParserManager$MultiUserTaskAction.run(ParserManager.java:191)
	at org.netbeans.modules.parsing.api.ParserManager$MultiUserTaskAction.run(ParserManager.java:163)
	at org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:206)
	at org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:203)
	at org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:176)
	at org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:360)
	at org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:74)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:203)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:108)
	at org.netbeans.api.java.source.JavaSource.runUserActionTaskImpl(JavaSource.java:443)
	at org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:414)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getLocalVerifiedSpans(BatchSearch.java:264)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.access$600(BatchSearch.java:99)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch$LocalIndexEnquirer.validateResource(BatchSearch.java:574)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getVerifiedSpans(BatchSearch.java:207)
	at org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch.getVerifiedSpans(BatchSearch.java:189)
	at org.netbeans.modules.java.hints.analysis.AnalyzerImpl.analyze(AnalyzerImpl.java:130)
	at org.netbeans.modules.analysis.RunAnalysis$1$1.doRunAnalyzer(RunAnalysis.java:209)
	at org.netbeans.modules.analysis.RunAnalysis$1$1.run(RunAnalysis.java:161)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2042)
ALL [null]: An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-gpw\pl\netpr\services\stock\gpw\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_4.dump'.
INFO [org.netbeans.modules.java.hints.spiimpl.batch.BatchSearch]: Exception while performing batch processing in C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-gpw\pl\netpr\services\stock\gpw\package-info.java
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-gpw\pl\netpr\services\stock\gpw\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_4.dump'.
An error occurred during parsing of 'C:\Users\Mirek\Documents\svn\trunk\services\target\generated-sources-gpw\pl\netpr\services\stock\gpw\package-info.java'. Please report a bug against java/source and attach dump file 'C:\Users\Mirek\AppData\Roaming\NetBeans\7.4rc2\var\log\package-info_4.dump'.
Caused: java.lang.AssertionError



WARNING [org.netbeans.JarClassLoader]: Opening C:\Program Files\NetBeans 7.4 RC2\platform\modules\org-netbeans-modules-sampler.jar took 11 910 ms
WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread org.netbeans.modules.sampler.InternalSampler@157ed068
WARNING [org.netbeans.core.TimableEventQueue]: no snapshot taken
SEVERE [global]
java.lang.OutOfMemoryError: Java heap space
	at java.awt.image.DataBufferInt.<init>(DataBufferInt.java:75)
	at java.awt.image.Raster.createPackedRaster(Raster.java:467)
	at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:1032)
	at java.awt.image.BufferedImage.<init>(BufferedImage.java:340)
	at com.sun.java.swing.plaf.windows.XPStyle$SkinPainter.createImage(XPStyle.java:673)
	at sun.swing.CachedPainter.paint0(CachedPainter.java:139)
	at sun.swing.CachedPainter.paint(CachedPainter.java:111)
	at com.sun.java.swing.plaf.windows.XPStyle$Skin.paintSkinRaw(XPStyle.java:610)
	at com.sun.java.swing.plaf.windows.AnimationController.paintSkin(AnimationController.java:253)
	at com.sun.java.swing.plaf.windows.XPStyle$Skin.paintSkin(XPStyle.java:589)
	at com.sun.java.swing.plaf.windows.WindowsTabbedPaneUI.paintRotatedSkin(WindowsTabbedPaneUI.java:223)
	at com.sun.java.swing.plaf.windows.WindowsTabbedPaneUI.paintContentBorder(WindowsTabbedPaneUI.java:150)
	at javax.swing.plaf.basic.BasicTabbedPaneUI.paint(BasicTabbedPaneUI.java:791)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
	at javax.swing.JComponent.paintComponent(JComponent.java:778)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at org.netbeans.swing.tabcontrol.TabbedContainer.paint(TabbedContainer.java:994)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5219)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1529)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1452)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5167)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4978)
[catch] at javax.swing.JComponent.paintImmediately(JComponent.java:4959)
WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread org.netbeans.modules.sampler.InternalSampler@4aed1486
WARNING [org.netbeans.core.TimableEventQueue]: no snapshot taken
WARNING [org.netbeans.core.TimableEventQueue]: too much time in AWT thread org.netbeans.modules.sampler.InternalSampler@316d194e
WARNING [org.netbeans.core.TimableEventQueue]: no snapshot taken
Comment 3 Martin Balin 2016-07-07 07:17:30 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo