Bug 236890 - CNFE after attaching to JDK8 ea b109 process
CNFE after attaching to JDK8 ea b109 process
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Engine
7.4
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Hurka
issues@profiler
74patch1-verified, bugdb_17753818
: JDK_8, VISUALVM
: 237993 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 16:12 UTC by sreimers
Modified: 2013-11-21 10:21 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2013-10-08 16:12:13 UTC
Just got this..

java.lang.ClassNotFoundException: java/util/LinkedHashMap$KeyIterator
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:258)
	at org.netbeans.lib.profiler.server.ProfilerInterface$InitiateProfilingThread.initiateInstrumentation(ProfilerInterface.java:174)
	at org.netbeans.lib.profiler.server.ProfilerInterface$InitiateProfilingThread.run(ProfilerInterface.java:136)
Comment 1 Tomas Hurka 2013-10-08 18:54:31 UTC
It is harmless.
Comment 2 Tomas Hurka 2013-10-10 12:30:57 UTC
Fixed in profiler-main

changeset:   264952:2ab9ee6ec5a0
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu Oct 10 14:20:58 2013 +0200
summary:     bugfix #236890, load LinkedHashMap inner classes via public API
Comment 3 Quality Engineering 2013-10-15 02:09:08 UTC
Integrated into 'main-silver', will be available in build *201310150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2ab9ee6ec5a0
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #236890, load LinkedHashMap inner classes via public API
Comment 4 Tomas Hurka 2013-11-05 12:17:04 UTC
*** Bug 237993 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Hurka 2013-11-13 09:19:57 UTC
Transplanted to release74

changeset:   275827:7a6dcb4deada
branch:      release74
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu Oct 10 14:20:58 2013 +0200
summary:     bugfix #236890, load LinkedHashMap inner classes via public API
Comment 6 Quality Engineering 2013-11-14 14:31:53 UTC
Integrated into 'releases/release74', will be available in build *201311141216* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/7a6dcb4deada
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #236890, load LinkedHashMap inner classes via public API
(transplanted from 2ab9ee6ec5a0c0f7f4edfab0152405f580836c57)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo