Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236789 - IllegalStateException: Node has been removed.
IllegalStateException: Node has been removed.
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.4
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT
:
: 255007 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-05 02:04 UTC by misterm
Modified: 2016-09-13 09:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.40 KB, text/plain)
2013-10-05 02:04 UTC, misterm
Details
stacktrace (1.42 KB, text/plain)
2014-02-09 17:07 UTC, hstenger
Details
stacktrace (1.69 KB, text/plain)
2016-08-06 07:46 UTC, IrianR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2013-10-05 02:04:15 UTC
Build: NetBeans IDE Dev (Build 20131002-e5b3233adb3d)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7

User Comments:
misterm: Saving project formatting options




Stacktrace: 
java.lang.IllegalStateException: Node has been removed.
   at java.util.prefs.AbstractPreferences.get(AbstractPreferences.java:283)
   at org.netbeans.modules.projectapi.AuxiliaryConfigBasedPreferencesProvider$AuxiliaryConfigBasedPreferences.access$1601(AuxiliaryConfigBasedPreferencesProvider.java:428)
   at org.netbeans.modules.projectapi.AuxiliaryConfigBasedPreferencesProvider$AuxiliaryConfigBasedPreferences$2.run(AuxiliaryConfigBasedPreferencesProvider.java:657)
   at org.netbeans.modules.projectapi.AuxiliaryConfigBasedPreferencesProvider$AuxiliaryConfigBasedPreferences$2.run(AuxiliaryConfigBasedPreferencesProvider.java:655)
   at org.openide.util.Mutex.readAccess(Mutex.java:295)
   at org.netbeans.modules.projectapi.AuxiliaryConfigBasedPreferencesProvider$AuxiliaryConfigBasedPreferences.get(AuxiliaryConfigBasedPreferencesProvider.java:655)
Comment 1 misterm 2013-10-05 02:04:17 UTC
Created attachment 140827 [details]
stacktrace
Comment 2 Milos Kleint 2013-10-07 08:38:58 UTC
reassigning to editor, ProxyPreferences appears to keep hold of Preferences nodes for some long amount of time (weak referenced listener present) but the preference nodes might not exist anymore..
Comment 3 hstenger 2014-02-09 17:07:26 UTC
Created attachment 144960 [details]
stacktrace

The following steps were perfomed on the Maven Java SE application project "QuickstartPrj".

Open project properties, go to Formatting, select "Use project specific options", select "All languages", change Tab Size, Right Margin and Ident spaces. Then press OK.

I had previously configured different Formatting settings for Java. They were saved to nb-configuration.xml but not used in the editor or shown after closing and re-opening the project properties.
Comment 4 Exceptions Reporter 2014-04-22 17:20:41 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=204382
Comment 5 manikantannaren 2015-08-28 03:18:54 UTC
Could not reproduce on build 201508270002
Comment 6 alied 2015-09-04 02:55:07 UTC
Could not reproduce:

Product Version: NetBeans IDE Dev (Build 201509030002)
Java: 1.8.0_60; Java HotSpot(TM) 64-Bit Server VM 25.60-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_60-b27
System: Linux version 4.1.6+ running on amd64; UTF-8; en_US (nb)
User directory: /home/alied/.netbeans/dev
Cache directory: /home/alied/.cache/netbeans/dev
Comment 7 skomisa 2015-10-04 06:19:14 UTC
Also could not reproduce. Everything worked fine: 

Product Version: NetBeans IDE 8.1 RC (Build 201510012201)
Java: 1.8.0_66-ea; Java HotSpot(TM) 64-Bit Server VM 25.66-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_66-ea-b02
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
User directory: C:\Users\JohnDoe\AppData\Roaming\NetBeans\8.1rc
Cache directory: C:\Users\JohnDoe\AppData\Local\NetBeans\Cache\8.1rc
Comment 8 Tomas Stupka 2016-07-13 15:46:18 UTC
*** Bug 255007 has been marked as a duplicate of this bug. ***
Comment 9 IrianR 2016-08-06 07:46:28 UTC
Created attachment 161578 [details]
stacktrace

Running test case:

http://services.netbeans.org/synergy/client/app/#/case/3855/suite/1920/v/1

from synergy
Comment 10 alied 2016-09-03 00:53:57 UTC
Could not reproduce (and I really tried):
Product Version: NetBeans IDE Dev (Build 201609020002)
Java: 1.8.0_102; Java HotSpot(TM) 64-Bit Server VM 25.102-b14
Runtime: Java(TM) SE Runtime Environment 1.8.0_102-b14
System: Linux version 4.7.2 running on amd64; UTF-8; en_US (nb)
Comment 11 skygo 2016-09-13 09:12:10 UTC
Seems ok for 
  8.2RC and jk8_112 

As alied was also not able to reproduce I change the status


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo