Bug 236521 - org.netbeans.lib.ddl.DDLException: Unable to execute command: use `nilaidb` Could not retrieve transation read-only status server
org.netbeans.lib.ddl.DDLException: Unable to execute command: use `nilaidb` C...
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: 8.0.1
Assigned To: Libor Fischmeistr
issues@db
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 16:55 UTC by Exceptions Reporter
Modified: 2015-07-27 19:00 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (680 bytes, text/plain)
2013-09-29 16:55 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-09-29 16:55:03 UTC
This bug was originally marked as duplicate of bug 209757, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 (Build 201306052037)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows 7

User Comments:
GUEST: Set a database in MySQL connection as Default Catalog.

GUEST: Not able to use database

GUEST: trying to connect to mysql database service




Stacktrace: 
org.netbeans.lib.ddl.DDLException: Unable to execute command:
use `nilaidb`
Could not retrieve transation read-only status server
   at org.netbeans.lib.ddl.impl.AbstractCommand.execute(AbstractCommand.java:244)
   at org.netbeans.modules.db.explorer.node.DDLHelper.setDefaultDatabase(DDLHelper.java:57)
   at org.netbeans.modules.db.explorer.DatabaseConnection.setDefaultCatalog(DatabaseConnection.java:591)
   at org.netbeans.modules.db.explorer.action.MakeDefaultCatalogAction$1.run(MakeDefaultCatalogAction.java:101)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2044)
Comment 1 Exceptions Reporter 2013-09-29 16:55:05 UTC
Created attachment 140623 [details]
stacktrace
Comment 2 matthias42 2015-07-27 19:00:13 UTC
In netbeans 8.* the exception is caught and the message reported in a dialog. It then depends on the jdbc driver how useful that is. As the IDE can't really determine the source of the error this is as good as possible.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo