Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236509 - [74cat] Scene Builder xmlns:fx versioning not properly recognized in NB Editor
[74cat] Scene Builder xmlns:fx versioning not properly recognized in NB Editor
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
7.4
PC All
: P2 with 1 vote (vote)
: 7.4
Assigned To: Svata Dedic
issues@javafx
74patch1-verified
: PLAN
: coco79 bernard79 (view as bug list)
Depends on:
Blocks: 236508 236511 236559 236620 236621 236624
  Show dependency treegraph
 
Reported: 2013-09-29 05:15 UTC by Lou Dasaro
Modified: 2013-12-20 03:54 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lou Dasaro 2013-09-29 05:15:35 UTC
When an fxml file is saved in Scene Builder, fxml version is carried e.g.:
xmlns:fx="http://javafx.com/fxml/1"

as specified by https://javafx-jira.kenai.com/browse/RT-28599 

and implemented in https://javafx-jira.kenai.com/browse/DTL-5739

HOWEVER, NetBeans Editor seems to only recognize xmlns:fx="http://javafx.com/fxml" and when the version is carried i.e. xmlns:fx="http://javafx.com/fxml/1", the editor treats as error but flags other elements as being in error.

See also Bug 236508
Comment 1 Lou Dasaro 2013-10-01 21:02:12 UTC
This breaks integration with Scene Builder. No workaround available using JavaFX Scene Builder 1.1 GA.
Comment 2 David Strupl 2013-10-01 21:28:36 UTC
I have marked it as P2 - the workaround is ugly but doable - after saving the file in SceneBuilder you delete the characters /1 in the namespace to fix the problem in the editor.
Comment 3 Lou Dasaro 2013-10-01 23:15:50 UTC
(In reply to David Strupl from comment #2)
> I have marked it as P2 - the workaround is ugly but doable - after saving
> the file in SceneBuilder you delete the characters /1 in the namespace to
> fix the problem in the editor.

Yes, you are correct. Every single time you save a file in Scene Builder 1.1 GA, using any version of NetBeans, you would have to manually make this edit.
Comment 4 Svata Dedic 2013-10-02 08:05:11 UTC
Fixed in dev, revision http://hg.netbeans.org/jet-main/rev/1d79bfe3e0cd
Comment 5 Svata Dedic 2013-10-02 08:52:10 UTC
*** Bug 236621 has been marked as a duplicate of this bug. ***
Comment 6 Lou Dasaro 2013-10-02 09:35:50 UTC
(In reply to Svata Dedic from comment #4)
> Fixed in dev, revision http://hg.netbeans.org/jet-main/rev/1d79bfe3e0cd

Thank you for your work on this - I am hopeful it will restore the integration
between NetBeans and Scene Builder!

Do you think the change will be in tonight's DEV build?
Comment 7 Lou Dasaro 2013-10-03 18:42:38 UTC
I don't see any change in http://bits.netbeans.org/download/trunk/nightly/latest/bundles/netbeans-trunk-nightly-201310030001-windows.exe

When/where can I test this fix, please? 

When can I test this fix in a Release Candidate, please?
Comment 8 Quality Engineering 2013-10-04 01:31:30 UTC
Integrated into 'main-silver', will be available in build *201310040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/1d79bfe3e0cd
User: Svata Dedic <sdedic@netbeans.org>
Log: #236509: Accept SceneBuilder 1.0 prefix and 1.1+ namespace prefixes
Comment 9 Lou Dasaro 2013-10-04 08:07:49 UTC
Verified in DEV. Needs patch for 7.4.
Comment 10 Svata Dedic 2013-10-07 08:20:06 UTC
*** Bug 236819 has been marked as a duplicate of this bug. ***
Comment 11 Lou Dasaro 2013-10-07 17:37:37 UTC
*** Bug 236817 has been marked as a duplicate of this bug. ***
Comment 12 Stepan Zebra 2013-11-13 12:24:59 UTC
please integrate into release74
Comment 14 Quality Engineering 2013-11-14 14:32:24 UTC
Integrated into 'releases/release74', will be available in build *201311141216* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/642e4f7faf5e
User: Svata Dedic <sdedic@netbeans.org>
Log: #236509: Accept SceneBuilder 1.0 prefix and 1.1+ namespace prefixes
Comment 15 Lou Dasaro 2013-11-22 17:15:41 UTC
Verified Fixed in NetBeans 7.4-patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo