Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236485 - Recognizing of static resources should be reconsidered
Recognizing of static resources should be reconsidered
Status: RESOLVED DUPLICATE of bug 218345
Product: javaee
Classification: Unclassified
Component: Maven
8.0
PC Mac OS X
: P2 with 10 votes (vote)
: 8.0.1
Assigned To: Martin Janicek
issues@javaee
80patch-candidate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 17:47 UTC by ender01
Modified: 2014-07-30 12:30 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ender01 2013-09-27 17:47:01 UTC
Environment: Maven 3, Tomcat 7, Netbeans Dev 201309270002, jdk 1.7_40

Reproduce: 

Create new Maven web project, point it to tomcat instance.
Add javascript file with simple console.log call
Deploy
Open project properties, go to 'Run' and uncheck deploy on save.
Edit index.jsp, reload page in browser (update works as expected)
change message in javascript file, save (reload page, JS message NOT updated)

Have encountered this for both older existing projects and new projects as well.


Let me know if you need anything else for details.
Comment 1 Martin Janicek 2013-09-30 13:30:36 UTC
Thanks for the report. I think this might be related to the enhancement I have implemented recently (Copy on Save for static resources). I'll take a look at it and let you know if I need something else.
Comment 2 Martin Janicek 2013-09-30 14:02:09 UTC
Fixed by change-set: web-main #a6191e1a0101
Also "css" extension were added as static resource.
Comment 3 Quality Engineering 2013-10-01 01:59:30 UTC
Integrated into 'main-silver', will be available in build *201310010002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a6191e1a0101
User: Martin Janicek <mjanicek@netbeans.org>
Log: #236485 - JS files not copied on save in maven web projects
Comment 4 eolivelli 2014-03-19 09:02:52 UTC
I have the same problem for .cfm files, which I registered a text/html file

I see from http://hg.netbeans.org/main-silver/rev/a6191e1a0101 that you consider a file as a "static resource" using the file extension

I propose these enhancements:
- consider files as "static resources" using MIME type mapping (every thing that is text/html, text/css, text/javascript....)
- consider files as "static resources" which is not to be "compiled", so for example everything which is not .java 
- add a flag "Consider this file type as a static resource" on file extension options
Comment 5 Martin Janicek 2014-03-21 07:44:11 UTC
Thanks for proposals. Changing to enhancement for now, setting TM = Next
Comment 6 eolivelli 2014-04-02 08:53:08 UTC
Is it possible to known where "NM" fill be released ?
My team cannot upgrade NetBeans to 8.0 (so we are stuck to 7.4) because for each change to static files we have to perform a full Run/deploy of the webapplication
Comment 7 eolivelli 2014-04-02 08:54:40 UTC
sorry for typo....I meant "when next milestone will be released?"
Comment 8 Martin Janicek 2014-07-30 12:30:50 UTC
Already fixed (change-set: web-main #de73823c63e8) within an issue 218345

*** This bug has been marked as a duplicate of bug 218345 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo