Bug 236126 - NullPointerException at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotationPositions.separateAnnotationsKinds
NullPointerException at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotati...
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 00:09 UTC by TimoKinnunen
Modified: 2015-09-17 11:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.14 KB, text/plain)
2013-09-19 00:09 UTC, TimoKinnunen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TimoKinnunen 2013-09-19 00:09:21 UTC
Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b48, Java(TM) SE Runtime Environment, 1.8.0-ea-b106
OS: Windows 8

User Comments:
TimoKinnunen: Double-clicked the file to see its contents after looking at another file.

TimoKinnunen: Doing undo on search and replace all changes in one file after copying the changes to another file.




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotationPositions.separateAnnotationsKinds(TypeAnnotations.java:309)
   at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotationPositions.visitMethodDef(TypeAnnotations.java:1041)
   at com.sun.tools.javac.tree.JCTree$JCMethodDecl.accept(JCTree.java:776)
   at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
   at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotationPositions.scan(TypeAnnotations.java:237)
   at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
Comment 1 TimoKinnunen 2013-09-19 00:09:23 UTC
Created attachment 140234 [details]
stacktrace
Comment 2 Martin Balin 2015-09-17 11:29:33 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo