Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236062 - Available plugins tooltips not in sync after sorting
Available plugins tooltips not in sync after sorting
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
8.0
PC Windows 7
: P4 (vote)
: 7.4
Assigned To: Jiri Rechtacek
au-issues
74patch2-verified
: NETFIX
: 236906 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 10:56 UTC by sentrox
Modified: 2013-12-10 10:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot showing the bug (95.75 KB, image/png)
2013-09-17 10:56 UTC, sentrox
Details
Proposed patch to resolve the issue (1.06 KB, patch)
2013-10-09 19:33 UTC, František Mantlík
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description sentrox 2013-09-17 10:56:03 UTC
Created attachment 140165 [details]
Screenshot showing the bug

- After sorting the table containing all available plugins in the plugin manager the tooltips are not in sync.

Product Version: NetBeans IDE Dev (Build 201309170002)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 7 version 6.1 running on x86; Cp1252; de_DE (nb)
User directory: C:\Users\smohr\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\smohr\AppData\Local\NetBeans\Cache\dev
Comment 1 markiewb 2013-09-17 18:18:49 UTC
Related to https://netbeans.org/bugzilla/show_bug.cgi?id=234685
Comment 2 markiewb 2013-09-17 18:28:21 UTC
@Jiri: P2 for a wrong tooltip? I guess not.
Comment 3 Jiri Kovalsky 2013-10-09 07:57:03 UTC
*** Bug 236906 has been marked as a duplicate of this bug. ***
Comment 4 František Mantlík 2013-10-09 19:33:57 UTC
Created attachment 140963 [details]
Proposed patch to resolve the issue

The submitted patch solves the problem on my system. Tested on NB 7.4 FCS Windows 7 64bit JDK 7u40.
Comment 5 Jiri Rechtacek 2013-10-10 19:05:39 UTC
(In reply to František Mantlík from comment #4)
> Created attachment 140963 [details]
> Proposed patch to resolve the issue
> 
> The submitted patch solves the problem on my system. Tested on NB 7.4 FCS
> Windows 7 64bit JDK 7u40.

Thanks for the patch. I'm going to apply the fix soon. Thanks again
Comment 6 Jiri Rechtacek 2013-10-11 10:27:33 UTC
http://hg.netbeans.org/core-main/rev/e5cee5f05382
Comment 7 Deldadam 2013-10-24 19:51:21 UTC
Hello All,

Is that patch in the curr. official v7.4 release included? Just because I'm experiencing exactly this issue on my fresh NB7.4 install... And not only on the 'Available Plugins' tab, but on the 'Downloaded', and 'Installed' tabs as well.

Thx.
Comment 8 František Mantlík 2013-10-24 20:06:21 UTC
Most probably not, I proposed the patch too late. It can be expected to be included in 7.4.1, I hope.
Comment 9 František Mantlík 2013-11-21 16:06:28 UTC
The patch is not included in 7.4 Patch 1?

Tested on:
Product Version: NetBeans IDE 7.4 (Build 201310111528)
Updates: NetBeans IDE is updated to version NetBeans 7.4 Patch 1
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 7 version 6.1 running on amd64; Cp1250; cs_CZ (nb)

Tooltips are still NOT in sync with plugin list after sorting.
Comment 10 Jiri Rechtacek 2013-11-22 10:35:52 UTC
(In reply to František Mantlík from comment #9)
> The patch is not included in 7.4 Patch 1?
Not, it has not a patch candidate status (intended for P1/2 issues). I marked it for patch2.
Comment 11 František Mantlík 2013-11-22 11:18:52 UTC
Thank you for your fast reaction. I expected that such a simple fix will be included into the next patch sequence automatically regardless of it's priority.
Comment 12 Jiri Rechtacek 2013-11-29 08:51:42 UTC
http://hg.netbeans.org/releases/rev/9f56a1ca354f
Comment 13 Quality Engineering 2013-12-05 01:34:14 UTC
Integrated into 'releases/release74', will be available in build *201312042201* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/9f56a1ca354f
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #236062 - Available plugins tooltips not in sync after sorting;
applied mantlik's patch; thanks
(transplanted from e5cee5f05382048fc7fe736f5988ae0b419ecf4e)
Comment 14 Tomas Danek 2013-12-06 10:47:21 UTC
verified in trunk Product Version: NetBeans IDE Dev (Build 201312060002)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Mac OS X version 10.9 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/dev
Cache directory: /Users/tomas/Library/Caches/NetBeans/dev
Comment 15 Tomas Danek 2013-12-10 10:24:42 UTC
verified in 7.4 + patch2

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Mac OS X version 10.9 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.4
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo