Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236060 - Not working help for "Rename" and both "Replace Constructor with *" refactorings
Not working help for "Rename" and both "Replace Constructor with *" refactorings
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: Java
7.4
PC Linux
: P2 (vote)
: 8.0
Assigned To: AlyonaStashkova
issues@usersguide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 09:33 UTC by Jiri Kovalsky
Modified: 2014-09-15 12:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2013-09-17 09:33:20 UTC
Product Version: NetBeans IDE 7.4 RC1 (Build 201309152201)
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b49
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b107
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/7.4rc1
Cache directory: /home/cesilko/.cache/netbeans/7.4rc1

Description:
============
"Help" button for "Rename", "Replace Constructor with Factory..." and "Replace Constructor with Builder..." refactorings.

Steps to reproduce:
===================
1. Launch NetBeans IDE.
2. Open MemoryView project.
3. Open MemoryView.java file and move cursor to constructor at line 46.
4. Invoke "Refactor > Rename..." from main menu and push "Help" button.
5. Invoke "Refactor > Replace Constructor with Factory..." from main menu and push "Help" button.
6. Invoke "Refactor > Replace Constructor with Builder..." from main menu and push "Help" button.
7. Help window is not opened.
Comment 1 Jaroslav Havlin 2013-09-17 11:14:16 UTC
The following help IDs aren't available:

org.netbeans.modules.refactoring.java.ui.RenameRefactoringUI.JavaClass
org.netbeans.modules.refactoring.java.ui.ReplaceConstructorWithFactoryUI
org.netbeans.modules.refactoring.java.ui.ReplaceConstructorWithBuilderUI

Reassigning to usersguide. Please evaluate it, thank you.
Comment 2 Kenneth Ganfield 2013-09-17 11:53:24 UTC
It looks like the help ids were changed between 7.3 and 7.4. The topics exist but are mapped to the following old help ids:

org.netbeans.modules.refactoring.java.ui.RenameRefactoringUI
org.netbeans.modules.java.hints.jackpot.refactoring.ReplaceConstructorWithFactoryUI
org.netbeans.modules.java.hints.jackpot.refactoring.ReplaceConstructorWithBuilderUI

If those ids were changed, the following help id for the Invert Boolean dialog might also be changed:
org.netbeans.modules.java.hints.jackpot.refactoring.InvertBooleanRefactoringUI

Can you confirm if this was also changed and if so give us the new id.

We can then update the map file in the usersguide for the new ids.
Comment 3 Kenneth Ganfield 2013-09-17 14:30:01 UTC
(In reply to Kenneth Ganfield from comment #2)

> If those ids were changed, the following help id for the Invert Boolean
> dialog might also be changed:
> org.netbeans.modules.java.hints.jackpot.refactoring.
> InvertBooleanRefactoringUI
> 
> Can you confirm if this was also changed and if so give us the new id.
> 
> We can then update the map file in the usersguide for the new ids.


Confirming that in 7.4 the help id for Invert Boolean refactoring dialog is:
org.netbeans.modules.refactoring.java.ui.InvertBooleanRefactoringUI
Comment 4 Jiri Kovalsky 2013-10-09 16:51:22 UTC
Well, Help window gets opened in FCS build but it's empty. Any chance to show the corresponding topics?
Comment 5 Kenneth Ganfield 2013-11-08 12:04:42 UTC
reassigning

Product Version: NetBeans IDE Dev (Build 201311080001)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Mac OS X version 10.8.5 running on x86_64; UTF-8; en_US (nb)

In the dev build the following ids are now mapped to the correct topics:
org.netbeans.modules.refactoring.java.ui.RenameRefactoringUI.JavaClass
org.netbeans.modules.refactoring.java.ui.ReplaceConstructorWithFactoryUI
org.netbeans.modules.refactoring.java.ui.ReplaceConstructorWithBuilderUI

The id 
org.netbeans.modules.refactoring.java.ui.RenameRefactoringUI.JavaClass
maps to the Rename Dialog topic.

However, the help id for the Rename refactoring dialog changes according to the type of element that is selected. The following ids are called when renaming the corresponding element.
org.netbeans.modules.refactoring.java.ui.RenameRefactoringUI.Method
org.netbeans.modules.refactoring.java.ui.RenameRefactoringUI.Field

These ids do not have corresponding topics.
Is it necessary to have three unique ids and three unique topics?

In the javahelp tool it is not possible to map multiple help ids to a single topics. So there must be either the same id for the different cases or a topic for each case.
Comment 6 AlyonaStashkova 2013-11-13 15:00:28 UTC
Added separate F1 topics for the Rename Method and Rename Field dialog boxes and mapped them to the respective help ids in both NB 7.4 and 8.0 csh books.
Leaving the issue open to verify on a product build.
Comment 7 Antonin Nebuzelsky 2014-02-14 11:28:18 UTC
Should this issue be closed fixed now?
Comment 8 AlyonaStashkova 2014-02-14 12:43:37 UTC
Verified using development build 201402040001.
Closing as fixed.
Comment 9 Jiri Kovalsky 2014-09-15 12:00:17 UTC
Product Version: NetBeans IDE 8.0.1 (Build 201408222300)
Java: 1.8.0_20; Java HotSpot(TM) 64-Bit Server VM 25.20-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_20-b26
System: Linux version 3.13.0-24-generic running on amd64; UTF-8; en_US (nb)
User directory: /home/cesilko/.netbeans/8.0.1
Cache directory: /home/cesilko/.cache/netbeans/8.0.1

Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo