Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236049 - NB froze while debugging
NB froze while debugging
Status: RESOLVED DUPLICATE of bug 235319
Product: platform
Classification: Unclassified
Component: Text
7.4
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 06:23 UTC by aquaglia
Modified: 2013-10-14 11:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aquaglia 2013-09-17 06:23:36 UTC
Product Version: NetBeans IDE 7.4 RC1 (Build 201309112301)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 7 version 6.1 running on amd64; Cp1252; en_GB (nb)
User directory: C:\Users\quaglan\AppData\Roaming\NetBeans\7.4rc1
Cache directory: C:\Users\quaglan\AppData\Local\NetBeans\Cache\7.4rc1


https://dl.dropboxusercontent.com/u/4422938/nbfrozen2/threaddump-1379398172477.zip
Comment 1 Martin Entlicher 2013-09-17 09:12:33 UTC
A problem at CloneableEditorInitializer.waitForFinishedInitialization(CloneableEditorInitializer.java:137)
It simply waits there and nobody notifies. :-(
Comment 2 aquaglia 2013-09-17 11:46:12 UTC
It has happened only once for now but I think it would be good to have the fix ready.
Comment 3 aquaglia 2013-09-24 11:41:13 UTC
It froze again:

https://dl.dropboxusercontent.com/u/4422938/nbfrozen2/20130924.zip
Comment 4 Miloslav Metelka 2013-10-14 11:41:33 UTC
The problem should be resolved by fix of issue 235319 which should be present in 7.4 RC2.
If the problem would still persist please reopen the issue.

*** This bug has been marked as a duplicate of bug 235319 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo