Bug 23602 - Jemmy2 - AbstractButtonOperator.push() should fail if button is disabled
Jemmy2 - AbstractButtonOperator.push() should fail if button is disabled
Status: CLOSED FIXED
Product: qa
Classification: Unclassified
Component: Code
3.x
Sun Solaris
: P1 (vote)
: TBD
Assigned To: issues@qa
issues@qa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-16 13:33 UTC by Jiri Skrivanek
Modified: 2011-02-17 09:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Test case to reproduce (1.73 KB, text/plain)
2002-06-07 10:17 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2002-05-16 13:33:12 UTC
In jemmy 1 there was waitComponentEnabled() before
mouse click. It should be there again.
Comment 1 Jiri Skrivanek 2002-06-07 10:07:02 UTC
Raising priority because it makes tests to fail. It appears when no
block action enables a button and push is called then (see test case).
Comment 2 Jiri Skrivanek 2002-06-07 10:17:33 UTC
Created attachment 6147 [details]
Test case to reproduce
Comment 3 Alexandre Iline 2002-06-12 02:42:46 UTC
waitCoponntEnabled added into push, press, release
320a322,326
>         try {
>             waitComponentEnabled();
>         } catch(InterruptedException e) {
>             throw(new 
JemmyException("Interrupted", e));
>         }
365a372,376
>         try {
>             waitComponentEnabled();
>         } catch(InterruptedException e) {
>             throw(new 
JemmyException("Interrupted", e));
>         }
375a387,391
>         try {
>             waitComponentEnabled();
>         } catch(InterruptedException e) {
>             throw(new 
JemmyException("Interrupted", e));
>         }

Comment 4 Jiri Skrivanek 2002-06-12 08:50:18 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo