Bug 236011 - RESTful JavaScript Client in Maven: wrong JS lib location
RESTful JavaScript Client in Maven: wrong JS lib location
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: REST
8.0
PC Linux
: P1 (vote)
: 7.4
Assigned To: Milan Kuchtiak
issues@webservices
: 74_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:42 UTC by Geertjan Wielenga
Modified: 2013-09-19 11:25 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geertjan Wielenga 2013-09-16 09:42:11 UTC
In a Java EE Maven project, when the RESTful JavaScript Client wizard is used, the JavaScript libraries are created in a 'libs' folder in the root of the Java EE Maven project. And the HTML file that is created can't find them when you deploy the application.

This is quite a serious bug, since HTML5 support in Java EE is one of our main features in NB 7.4.

Steps to reproduce:

http://www.youtube.com/watch?v=gIEBo2AUDkA
Comment 1 Petr Jiricka 2013-09-16 13:11:20 UTC
Milan, can you please investigate?
Comment 2 Milan Kuchtiak 2013-09-16 14:18:17 UTC
Yes, when the "Add Backbone.js to project sources" option is used, the JavaScript files are put under project root folder, which is not included into war file, so the libraries are not available during runtime.

This is the same in ant projects.

The wizard was originally developped for HTML5 applications, then decided to re-use in ant/maven web projects.
Comment 3 Milan Kuchtiak 2013-09-16 15:07:59 UTC
The issue is fixable for 7.4.
Comment 4 Milan Kuchtiak 2013-09-17 09:01:34 UTC
Fixed in trunk:
http://hg.netbeans.org/web-main/rev/479ac9934a7d

The issue is quite serious, since JavaScript libraries, not located under document root, are unusable.
I am qualifying the issue as a stopper.

Jirka, could you please verify the fix ?
Comment 5 Petr Jiricka 2013-09-17 09:20:27 UTC
I guess this should be verified by Stepan, cc'ing.
Comment 6 Milan Kuchtiak 2013-09-17 09:21:32 UTC
One more correction in if statement:
http://hg.netbeans.org/web-main/rev/b73d274a34ff
Comment 7 Marek Fukala 2013-09-17 11:46:50 UTC
479ac9934a7d+b73d274a34ff looks ok to me.
Comment 8 Quality Engineering 2013-09-18 02:09:03 UTC
Integrated into 'main-silver', will be available in build *201309180002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/479ac9934a7d
User: Milan Kuchtiak <mkuchtiak@netbeans.org>
Log: #236011 fix target directory for JavaScript files and HTML file in RESTful JavaScript client wizard
Comment 9 Jiri Skrivanek 2013-09-19 08:56:12 UTC
Verified in NetBeans IDE Dev (Build 201309190428). Generated JavaScript files are under Web Pages node.
Comment 10 Milan Kuchtiak 2013-09-19 11:25:06 UTC
Thanks for the review.

Fixed in release74 branch:

Changesets:
3f02dbb7217b
306b5251afd9


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo