Bug 235950 - AssertionError: Can't annotate already annotated type: (@some.Any :: some.Outer.Middle.Inner); adding: @some.Counted
AssertionError: Can't annotate already annotated type: (@some.Any :: some.Out...
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 18:00 UTC by TimoKinnunen
Modified: 2015-09-17 11:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (10.08 KB, text/plain)
2013-09-13 18:00 UTC, TimoKinnunen
Details
Full contents of NetBeansProjects folder that cause this error to show (155.69 KB, application/x-zip-compressed)
2013-09-18 16:27 UTC, TimoKinnunen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TimoKinnunen 2013-09-13 18:00:12 UTC
Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b48, Java(TM) SE Runtime Environment, 1.8.0-ea-b106
OS: Windows 8

User Comments:
TimoKinnunen: Please see Bug 235948 for the requested dump file and description.




Stacktrace: 
java.lang.AssertionError: Can't annotate already annotated type: (@some.Any :: some.Outer.Middle.Inner); adding: @some.Counted
   at com.sun.tools.javac.util.Assert.error(Assert.java:133)
   at com.sun.tools.javac.util.Assert.check(Assert.java:94)
   at com.sun.tools.javac.code.Type$AnnotatedType.<init>(Type.java:1622)
   at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotationPositions$1.visitAnnotatedType(TypeAnnotations.java:551)
   at com.sun.tools.javac.code.TypeAnnotations$TypeAnnotationPositions$1.visitAnnotatedType(TypeAnnotations.java:530)
   at com.sun.tools.javac.code.Type$AnnotatedType.accept(Type.java:1659)
Comment 1 TimoKinnunen 2013-09-13 18:00:18 UTC
Created attachment 140063 [details]
stacktrace
Comment 2 TimoKinnunen 2013-09-18 16:27:13 UTC
Created attachment 140222 [details]
Full contents of NetBeansProjects folder that cause this error to show

Steps to reproduce:
1. Start NetBeans with problematic projects in NetBeansProjects folder.
2. Double-click Outer.java in project Tests.
Comment 3 Martin Balin 2015-09-17 11:29:13 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo