Bug 235852 - Error Using Lombok.jar
Error Using Lombok.jar
Status: RESOLVED DUPLICATE of bug 226165
Product: java
Classification: Unclassified
Component: Compiler
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 04:31 UTC by harunmip
Modified: 2013-09-19 10:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (226.58 KB, text/plain)
2013-09-12 04:31 UTC, harunmip
Details

Note You need to log in before you can comment on or make changes to this bug.
Description harunmip 2013-09-12 04:31:22 UTC
Product Version = NetBeans IDE 7.4 Beta (Build 201307092200)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_15
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01

Can't initialize javac processor due to (most likely) a class loader problem: java.lang.NoClassDefFoundError: com/sun/tools/javac/code/TypeTags
  	at lombok.javac.handlers.HandleGetter.<clinit>(HandleGetter.java:296)
  	at java.lang.Class.forName0(Native Method)
  	at java.lang.Class.forName(Class.java:266)
  	at lombok.core.SpiLoadUtil$1$1.next(SpiLoadUtil.java:111)
  	at lombok.javac.HandlerLibrary.loadAnnotationHandlers(HandlerLibrary.java:107)
  	at lombok.javac.HandlerLibrary.load(HandlerLibrary.java:94)
  	at lombok.javac.JavacTransformer.<init>(JavacTransformer.java:43)
  	at lombok.javac.apt.Processor.init(Processor.java:81)
  	at lombok.core.AnnotationProcessor$JavacDescriptor.want(AnnotationProcessor.java:89)
  	at lombok.core.AnnotationProcessor.init(AnnotationProcessor.java:143)
  	at com.sun.tools.javac.processing.JavacProcessingEnvironment$ProcessorState.<init>(JavacProcessingEnvironment.java:517)
  	at com.sun.tools.javac.processing.JavacProcessingEnvironment$DiscoveredProcessors$ProcessorStateIterator.next(JavacProcessingEnvironment.java:617)
  	at com.sun.tools.javac.processing.JavacProcessingEnvironment.discoverAndRunProcs(JavacProcessingEnvironment.java:710)
  	at com.sun.tools.javac.processing.JavacProcessingEnvironment.access$2000(JavacProcessingEnvironment.java:98)
  	at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.run(JavacProcessingEnvironment.java:1037)
  	at com.sun.tools.javac.processing.JavacProcessingEnvironment.doProcessing(JavacProcessingEnvironment.java:1100)
  	at com.sun.tools.javac.main.JavaCompiler.processAnnotations(JavaCompiler.java:1206...
Comment 1 harunmip 2013-09-12 04:31:28 UTC
Created attachment 139961 [details]
IDE log
Comment 2 Jiri Prox 2013-09-19 10:20:27 UTC

*** This bug has been marked as a duplicate of bug 226165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo