Bug 235746 - NullPointerException at com.sun.tools.javac.util.Log$DeferredDiagnosticHandler.report
NullPointerException at com.sun.tools.javac.util.Log$DeferredDiagnosticHandle...
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 13:11 UTC by tomzi
Modified: 2015-09-17 11:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.33 KB, text/plain)
2013-09-10 13:11 UTC, tomzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2013-09-10 13:11:46 UTC
Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b15
OS: Linux

User Comments:
tomzi: Refactor method




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.util.Log$DeferredDiagnosticHandler.report(Log.java:148)
   at com.sun.tools.javac.util.Log.report(Log.java:624)
   at com.sun.tools.javac.util.AbstractLog.warning(AbstractLog.java:159)
   at com.sun.tools.javac.comp.Attr.findDiamondIfNeeded(Attr.java:2261)
   at com.sun.tools.javac.comp.Attr.visitNewClass(Attr.java:2126)
   at com.sun.tools.javac.tree.JCTree$JCNewClass.accept(JCTree.java:1514)
Comment 1 tomzi 2013-09-10 13:11:49 UTC
Created attachment 139880 [details]
stacktrace
Comment 2 Martin Balin 2015-09-17 11:28:51 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo