Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 235354 - Add support for Codeception framework
Add support for Codeception framework
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Project
7.4
All All
: P2 with 16 votes (vote)
: 8.1
Assigned To: Tomas Mysik
issues@php
:
: 246240 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 02:09 UTC by songoko20000
Modified: 2015-07-18 01:46 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description songoko20000 2013-09-01 02:09:24 UTC
It would be great if Netbeans added support for Codeception framework (http://codeception.com/).

Codeception is used for doing both Functional,Story and Unit testing testing in addition to BDD.
Comment 1 bugmenot1 2014-02-12 14:27:29 UTC
If you want to run all tests and exclude codeception tests in Netbeans you have to use this ugly hack. Put this at the top of your test file:

if (!class_exists('Codeception\TestCase\Test')) {
    return;
}

I tried exclude dir in phpunit config file, add tests to special group, but always when I tried to run all tests Netbeans fail:

Fatal error: Class 'Codeception\TestCase\Test' not found in ...
Comment 2 Tomas Mysik 2015-07-15 06:17:52 UTC
*** Bug 246240 has been marked as a duplicate of this bug. ***
Comment 3 Tomas Mysik 2015-07-15 07:28:01 UTC
Junichi has created a plugin for Codeception [1]. This plugin could be part of standard distribution of NetBeans soon.

Thanks Junichi!
[1] https://bitbucket.org/junichi11/nb-codeception
Comment 4 andrewpk 2015-07-15 13:33:17 UTC
(In reply to Tomas Mysik from comment #3)
> Junichi has created a plugin for Codeception [1]. This plugin could be part
> of standard distribution of NetBeans soon.
> 
> Thanks Junichi!
> [1] https://bitbucket.org/junichi11/nb-codeception

This is pretty awesome. Thanks!
Comment 5 Tomas Mysik 2015-07-17 06:43:50 UTC
Support has been added. Please, test it and report all the issues you find.

Thanks.

http://hg.netbeans.org/web-main/rev/22d3bce0eaee
Comment 6 Quality Engineering 2015-07-18 01:46:47 UTC
Integrated into 'main-silver', will be available in build *201507180001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/22d3bce0eaee
User: Tomas Mysik <tmysik@netbeans.org>
Log: #235354 - Add support for Codeception framework

Patch contributed by junichi11@netbeans.org.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo