Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 235343 - project group (none) stop working
project group (none) stop working
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.4
PC Windows 7
: P3 (vote)
: 8.0.1
Assigned To: Martin Kozeny
issues@projects
:
: 153079 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 10:03 UTC by maxym
Modified: 2013-10-23 12:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maxym 2013-08-31 10:03:44 UTC
While looking a way to stop NB loading all (more than 30) projects at start, I found group feature to be a candidate.

I added a group, assigned a project... everything works till now.
But how to get again list of all projects?

Selecting '(none)' group doesn't work - project list window turns to empty.
Removing added group - didn't help - no project on the list
Restarting NB - didn't changed anything.

So, in short, I've lost complete list of all projects. I'm sure it's not how it should work?
Tested with:
Product Version: NetBeans IDE Dev (Build 201308280001)
Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Windows 7 version 6.1 running on amd64; Cp1250; cs_CZ (nb)


I found description of the feature on wiki: http://wiki.netbeans.org/ProjectGroups
Besides, this document doesn't match current state (compared to NB7.4devel) I found there following sentence:

"Initially there is no group open and you can switch back to this null group to disable the group feature for a while."

I understand that ('none') group is meant.
So, as I reported, it is not possible to disable the feature.
Could someone help me, how to get all my projects back onto project list?

Further findings 
Let's assume someone has a lot of projects, while there is no intention to group them. Such programmer doesn't use groups feature at all but he suffers from long loading time anytime he starts NB. Of course he may create a group for each single project, but does it make any sense to do additional work just to achieve basic feature (project independence)?
Additionally navigating between groups is not as handy as switching between projects: there is no group list window - you have to use File menu.
Personally, I would like to work with project list, but open only single one at the time, or open projects on demand - not all ones at NB start.
Please consider some optimizations in this area or point me to the features if already exist. Thank you.

Best regards
Comment 1 maxym 2013-10-09 13:23:25 UTC
Guys, any info about it?
Is it normal that the issue is not even checked/confirmed?
Comment 2 Milos Kleint 2013-10-09 13:42:20 UTC
fine, I'm explicitly confirming, however unlikely to be fixed in near future.
Comment 3 Martin Kozeny 2013-10-14 15:00:44 UTC
Project Groups were completely reorganized. Should work fine now. If not, feel free to reopen.
Comment 4 maxym 2013-10-14 20:15:38 UTC
Thanx for progress.
However switching to '(none)' group doesn't make all projects shown. I get blank list.

Regarding layout: I would rather see it as dockable window (the same like projects or files etc), with features accessed via context menu. It would be more consistent with current NB layout. 

And BTW: there is still no option to remove project from the group. I reported the issue here: https://netbeans.org/bugzilla/show_bug.cgi?id=236946
Comment 5 Martin Kozeny 2013-10-16 13:25:34 UTC
(In reply to maxym from comment #4)
> Thanx for progress.
> However switching to '(none)' group doesn't make all projects shown. I get
> blank list.

Yeah you're right. None goup make poblems, b/c when you open some projects in this group, then switch to some named group and then switch back to None group, you'll get the empty list and I agree, that this could be problem. None project group only persists when closing IDE.

> Regarding layout: I would rather see it as dockable window (the same like
> projects or files etc), with features accessed via context menu. It would be
> more consistent with current NB layout. 

> And BTW: there is still no option to remove project from the group. I
> reported the issue here: https://netbeans.org/bugzilla/show_bug.cgi?id=236946

This two things are according to me connected together, b/c as far as I understand your requirements you want to add and remove projects without necessity of opening whole project group (now you have to open whole group and close particular project(s)).
Comment 6 maxym 2013-10-17 23:25:13 UTC
> Yeah you're right. None goup make poblems, b/c when you open some projects in this group, then switch to some named group and then switch back to None group, you'll get the empty list and I agree, that this could be problem. None project group only persists when closing IDE.

I believe we both agree it should be improved in some way.
I think a beginner NB user just adds new projects to NB (unwittingly to NONE group). Probably after some time he find groups and will start to work with them. Unfortunately after creation of the first group he basically will lost access to all other projects, until he create groups for each of them. It may be annoying especially if he works on a lot of projects.

So... I think, since base philosophy of NB is to work with single projects, there should be option to show list of all projects at once, in any time.

> This two things are according to me connected together, b/c as far as I understand your requirements you want to add and remove projects without necessity of opening whole project group (now you have to open whole group and close particular project(s)).

Actually those 2 things are not connected imo.
Layout is not comfy to me, because I have a few multi-project groups which I don't want to mix together, but I often need to switch between them. Having group list in dockable window would really help me.

Missing remove project from group feature, was my mistake. I haven't figure out that I just can to close the project. FYI, while working with some group, I had to temporary add a project to it. Then I just haven't managed how to remove the project. Now it's clear to me.
Comment 7 Martin Kozeny 2013-10-22 15:35:17 UTC
None group is now working fine:
https://hg.netbeans.org/core-main/rev/907fc36ecf44

Dockable window for project groups is not planned to be developed. It would be to hard to connect with rest of the IDE. Sorry.
Comment 8 maxym 2013-10-22 16:23:21 UTC
> Dockable window for project groups is not planned to be developed. It would be to hard to connect with rest of the IDE. Sorry.

Don't understand how to add another window with basically the same functionality but easier access than we have today may be hard. Whatever..

Really bad then because we are left with choice:
* work comfortably with multiple projects (but this is affected by performance limits at least)
* work with groups but suffer from far from comfy group switch. 

I don't know what is the proper target for NB: professionals or just students who are working on a single project a year. Sad, that the first group must suffer.

however thanx for honest answer.
Comment 9 Martin Kozeny 2013-10-23 10:46:41 UTC
*** Bug 153079 has been marked as a duplicate of this bug. ***
Comment 10 Martin Kozeny 2013-10-23 10:53:32 UTC
Don't understand why you feel uncomfortable with actual solution? It's just you're afraid of mixing projects across groups?
Comment 11 maxym 2013-10-23 11:33:17 UTC
I've commented the method of switching between groups and what you said:
> Dockable window for project groups is not planned to be developed.

Current solution is sufficient in case of switching between groups rarely. 
When you have to switch between groups often, then current solution may be p.i.a. 
Let's look at the dotay's scenario:
- find option in context menu 
- find a group on the list (window has fixed size, you have often to scroll the list assuming you have more groups)
- select group 
- doubleclick or click a button

I believe it would be just far more comfortable and quicker to click the group on the list which is a part of dockable window. Usually (due to your preferences) such window may be always visible, it's vertical size may be greater, may be located wherever you want (ie on 3rd monitor etc). Switching to another group might be just matter of click always visible item.

BTW: (none) group indeed do work again as expected.
Comment 12 Milos Kleint 2013-10-23 11:33:54 UTC
(In reply to maxym from comment #8)
> > Dockable window for project groups is not planned to be developed. It would be to hard to connect with rest of the IDE. Sorry.
> 
> Don't understand how to add another window with basically the same
> functionality but easier access than we have today may be hard. Whatever..

Well, a dialog only contains a snapshot of the dataset, while persistent dockable windows need to react to all kind of changes. 

> 
> Really bad then because we are left with choice:
> * work comfortably with multiple projects (but this is affected by
> performance limits at least)

How many projects are we actually talking about? What kind of projects? in general it's fairly common for users to have 20+ projects, or even 100.


> * work with groups but suffer from far from comfy group switch. 

switching a project group is not a cheap operation, opening and closing projects is fairly expensive in terms of CPU (and subsequently also memory)
Comment 13 maxym 2013-10-23 12:02:55 UTC
I have a lot of projects grouped into groups of 3.
Switching between them performs quick. To me, manual operations needed to switch between groups takes more time/effort than switching process itself.

Guys, I'm simply saying that it might be more comfortable. When I've worked without using groups, it was perfect, except of time needed to scan projects. The time which grown with any new project added. Groups feature shorten scanning time significantly, which made this way the main to me. However I found switching between groups a bit annoying (but it may be not issue for everyone - I just must switch between groups often). So, it's all about makes things more ergonomic. 

with regards.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo