Bug 235328 - org.netbeans.modules.autoupdate.ui.DetailsPanel.setText: LowPerformance took 72805 ms.
org.netbeans.modules.autoupdate.ui.DetailsPanel.setText: LowPerformance took ...
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.3
All All
: P3 (vote)
: 8.0
Assigned To: Jiri Rechtacek
au-issues
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 16:28 UTC by Exceptions Reporter
Modified: 2013-09-09 08:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (530.59 KB, application/nps)
2013-08-30 16:28 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-08-30 16:28:42 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows Vista

User Comments:
GUEST: > I was downloading windows updates
> Browsing the internet 
> NetBeans was scanning background changes



Maximum slowness yet reported was 72805 ms, average is 38313
Comment 1 Exceptions Reporter 2013-08-30 16:28:47 UTC
Created attachment 139509 [details]
nps snapshot
Comment 2 Jiri Rechtacek 2013-09-09 08:08:58 UTC
Caused by loading sun.font.SunFontManager() which reads fonts from disk. Cannot be improved on NetBeans platform side.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo