Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 235319 - ReusableEditor2Test failures.
ReusableEditor2Test failures.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Text
7.4
All All
: P1 (vote)
: 7.4
Assigned To: Miloslav Metelka
issues@editor
http://deadlock.netbeans.org/job/NB-C...
: 7.4_HR_FIX, RANDOM, TEST
: 236049 236081 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 14:10 UTC by Martin Entlicher
Modified: 2013-10-14 11:41 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Console text (1.61 MB, application/x-gzip)
2013-08-30 14:15 UTC, Martin Entlicher
Details
Sometimes it gets to the next test and fails at ReusableEditorTest (1.61 MB, application/x-gzip)
2013-08-30 14:19 UTC, Martin Entlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2013-08-30 14:10:47 UTC
This test often fails in NB-Core-Build builder.
Recently it has failed on Aug 27, two times on Aug 28 and at least two times on Aug 30.
See the attached output.
Comment 1 Martin Entlicher 2013-08-30 14:15:08 UTC
Created attachment 139496 [details]
Console text
Comment 2 Martin Entlicher 2013-08-30 14:19:08 UTC
Created attachment 139499 [details]
Sometimes it gets to the next test and fails at ReusableEditorTest
Comment 3 Miloslav Metelka 2013-09-05 23:16:37 UTC
After fixing of issue 234781 I'm no longer able to reproduce any random openide.text tests failures so optimistically marking as duplicate.
If the problem persists please reopen.

*** This bug has been marked as a duplicate of bug 234781 ***
Comment 4 Martin Entlicher 2013-09-06 18:33:14 UTC
Unfortunately, it still fails, sometimes. :-(
http://deadlock.netbeans.org/job/NB-Core-Build/378/console
Comment 5 Miloslav Metelka 2013-09-15 12:25:20 UTC
Unfortunately I still cannot reproduce ReusableEditorTest and ReusableEditor2Test on any of my machines and VirtualBox instances but I've at least attempted to improve robustness of the CloneableEditorInitializer. I'll wait few builds and check if the continuous build would fail again and possibly reopen the issue.
I've experienced NotifyModifyTest failing once. Currently the reload threading is a bit diferent - it requires one extra pre-reload part posted into EDT and also (potentially long) loading part running outside of EDT (as requested by an issue to not use input stream from EDT). Hopefully fixed the NotifyModifyTest.
Also I've updated DocumentCannotBeClosedWhenReadLockedTest to use count down latches instead of wait/notify mechanism which was failing for me ocassionally and also reproducibly when running the test under debugger.

http://hg.netbeans.org/jet-main/rev/a410c353a968
Comment 6 Miloslav Metelka 2013-09-18 13:33:30 UTC
It looks like the last fix helped and the build no longer fails on the tests and no ReusableEditor2Test appears failing.

I would like to ask QE for review since I would like to integrate into release74.
I'd like to ask Honza L. for review. Thanks.
Comment 7 Jan Lahoda 2013-09-20 11:00:29 UTC
I think the patch can be backported to release74.
Comment 8 Jiri Prox 2013-09-23 11:39:51 UTC
verified in trunk
Comment 9 Miloslav Metelka 2013-09-24 08:50:41 UTC
In release74:
a410c353a968 transplanted to e77ec40e102a
Comment 10 Miloslav Metelka 2013-09-24 11:28:27 UTC
*** Bug 236081 has been marked as a duplicate of this bug. ***
Comment 11 Miloslav Metelka 2013-10-14 11:41:33 UTC
*** Bug 236049 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo