Bug 235257 - Something must crash (cannot use the IDE afterwards)
Something must crash (cannot use the IDE afterwards)
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Embedded Browser
7.3.1
Macintosh (x86) Mac OS X
: P3 (vote)
: 8.0
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 15:47 UTC by davide_c
Modified: 2013-12-06 14:25 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE profile snapshot (124.49 KB, application/octet-stream)
2013-08-31 09:44 UTC, davide_c
Details
Log (36.82 KB, application/octet-stream)
2013-09-03 08:57 UTC, davide_c
Details
Screenshot - Before crash (232.20 KB, image/png)
2013-09-05 13:58 UTC, davide_c
Details
Screenshot - After Crash 1 (226.19 KB, image/png)
2013-09-05 13:59 UTC, davide_c
Details
Screenshot - After Crash 2 (228.98 KB, image/png)
2013-09-05 14:00 UTC, davide_c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davide_c 2013-08-29 15:47:21 UTC
In an HTML5 app project, I'm keeping a window open with the embed browser beside the source code window. 

At some point, apparently whenever I click on a "Select" (HTML tag, drop down menu in other words) in the embedded browser window (the rendering of my html page), something crashes: I cannot type anymore and I notice that the menu bar only shows only NetBeans->"Quit ava" instead of the normal menu.

This happens all the time, making it impossible to use the IDE with embedded webkit. It also happens on the Netbeans 7.4 Beta.
Comment 1 markiewb 2013-08-30 23:41:55 UTC
Please provide the IDE log. A threaddump and a sampling snapshot (taken via JVisualVM) would also be useful for the diagnostics.
Comment 2 davide_c 2013-08-31 09:44:30 UTC
Created attachment 139524 [details]
IDE profile snapshot

Uploaded IDE log (taken with NetBeans 7.4 Beta. Although, it happens on 7.3 as well).
Comment 3 David Konecny 2013-09-02 20:31:00 UTC
IDE log can be accessed via top level menu View -> IDE Log. Could you attach it please?

The profilling snapshot you've attached does not show anything unsual I think. I suspect that problem is directly in JavaFX implementation of embedded browser on your Mac platform. CCing PetrJ who has been running embedded browser on Mac without problems.

Does embedded browser has problems rendering any html page or does it fail only on certain pages?
Comment 4 davide_c 2013-09-03 08:04:31 UTC
After the crash happened, the menu is not available anymore, so I cannot access View->IDE Log.

However, I've got good news. The issue is 100% reproducible.

1) Just create a new HTML5 project

2) In the index.html file add a simple select as follows:
<!DOCTYPE html>
<html>
    <head>
        <title>TODO supply a title</title>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <meta name="viewport" content="width=device-width">
    </head>
    <body>
        <div>TODO write content</div>
        <select>
            <option>abc1</option>
            <option>abc2</option>
            <option>abc3</option>
        </select>
    </body>
</html>

3) Then select "Embedded Webkit Browser" and Run the application.

4) The page is shown correctly in the embedded browser.

5) Now click on Select (dropdown) and you'll see the crash.

Please et me know if you have any problem in reproducing the issue.
Comment 5 Vladimir Riha 2013-09-03 08:33:12 UTC
Thank for the steps, it works for me on linux. 

You can find IDE log file "manually", see [1] so please upload it here once the crash happens. It will also contain used JDK which could be important. Thank you


[1] http://wiki.netbeans.org/FaqLogMessagesFile
Comment 6 davide_c 2013-09-03 08:57:50 UTC
Created attachment 139610 [details]
Log

I noticed that at the moment I click on the dropdown (which is what triggers the issue) the following lines are added to the log (as you can see those are the last lines at the bottom of the attached log):

WARNING [org.netbeans.modules.options.keymap.LayersBridge]: Invalid shortcut: org.openide.loaders.BrokenDataShadow@517b578b[MultiFileObject@68831113[Keymaps/NetBeans/D-BACK_QUOTE.shadow]]
WARNING [org.netbeans.modules.options.keymap.LayersBridge]: Invalid shortcut: org.openide.loaders.BrokenDataShadow@517b578b[MultiFileObject@68831113[Keymaps/NetBeans/D-BACK_QUOTE.shadow]]

Please let me know if other information are needed (as said this is happening on Mac OS, 10.8.4)
Comment 7 Petr Jiricka 2013-09-03 15:52:41 UTC
Hi, I remember seeing problems like this before, when the main menu disappears. This is definitely a problem in JDK or JavaFX itself. 

I see you are using JDK 1.7.0_21, can you please try updating to the latest release? Currently version 1.7.0_25 is available. 

If that does not help, then a couple weeks the next update release (update 40) will be available, and this update fixes quite many bugs on Mac. You can download an "early access" build for this update at http://jdk7.java.net/download.html - that may also be worth trying?

BTW, which model of Mac do you use? I know that some problems only affect some Mac models, e.g. Retina displays cause more problems than non-Retina.
Comment 8 David Konecny 2013-09-03 22:45:53 UTC
Log unfortunately does not contain anything relevant either. There is 

INFO [org.netbeans.core.browser.webview.ext.WebBrowserImpl]
java.lang.Throwable: Connection refused by server
[catch] at javafx.scene.web.WebEngine$LoadWorker.describeError(WebEngine.java:1147)
...

but that could be a valid case of a typo in a resource URL or simply missing resource. Considering the simplicity of the test case this is likely a JDK or JavaFX issue.
Comment 9 davide_c 2013-09-04 05:44:43 UTC
I'm using a Mac Book Pro, year 2008 (2.4GHz Core 2 Duo), so no retina display. I'll try to update from Java 1.7.0_21 to 1.7.0_25 as soon as possible, thanks.
(In reply to Petr Jiricka from comment #7)
> Hi, I remember seeing problems like this before, when the main menu
> disappears. This is definitely a problem in JDK or JavaFX itself. 
> 
> I see you are using JDK 1.7.0_21, can you please try updating to the latest
> release? Currently version 1.7.0_25 is available. 
> 
> If that does not help, then a couple weeks the next update release (update
> 40) will be available, and this update fixes quite many bugs on Mac. You can
> download an "early access" build for this update at
> http://jdk7.java.net/download.html - that may also be worth trying?
> 
> BTW, which model of Mac do you use? I know that some problems only affect
> some Mac models, e.g. Retina displays cause more problems than non-Retina.
Comment 10 Petr Jiricka 2013-09-04 11:30:09 UTC
Cc'ing Standa as the Swing guru who also implemented the embedded browser.
Comment 11 Stanislav Aubrecht 2013-09-04 11:45:06 UTC
Reporter, please attach a screen shot of the IDE main window when problem happens again, thanks.
Comment 12 davide_c 2013-09-05 13:58:29 UTC
Created attachment 139705 [details]
Screenshot - Before crash
Comment 13 davide_c 2013-09-05 13:59:35 UTC
Created attachment 139706 [details]
Screenshot - After Crash 1
Comment 14 davide_c 2013-09-05 14:00:39 UTC
Created attachment 139707 [details]
Screenshot - After Crash 2
Comment 15 davide_c 2013-09-05 14:04:06 UTC
Added screeshots before and after as requested. Hope it helps.
As said, on my Mac, the issue is 100% reproducible. Is that happening only on my machine or is anyone else able to reproduce it too (following the steps reported above)?
Comment 16 David Konecny 2013-09-05 21:17:41 UTC
This is very likely JavaFX WebKit browser issue and should be reported elsewhere.
Comment 17 Stanislav Aubrecht 2013-09-16 14:56:51 UTC
The steps from comment #4 work fine for me in 

Product Version: NetBeans IDE Dev (Build 20130916-c70779d8b4a6)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Mac OS X version 10.8.5 running on x86_64; UTF-8; en_US (nb)
Comment 18 Stanislav Aubrecht 2013-12-06 14:25:52 UTC
Still cannot reproduce in

Product Version: NetBeans IDE Dev (Build 20131125-5f4e1598a7f9)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Mac OS X version 10.9 running on x86_64; UTF-8; en_US (nb)

Reporter, please reopen if the issue is still reproducible for you, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo