Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 235089 - ArrayIndexOutOfBoundsException: 45401
ArrayIndexOutOfBoundsException: 45401
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: FindBugs
7.4
All All
: P2 (vote)
: 8.0
Assigned To: Petr Cyhelsky
issues@java
EXCEPTIONS_REPORT
: 8.0_HR_FIX, JDK_8
: 233011 237187 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 11:25 UTC by MarPiRK
Modified: 2014-02-25 08:11 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.08 KB, text/plain)
2013-08-27 11:25 UTC, MarPiRK
Details
stacktrace (3.54 KB, text/plain)
2013-10-29 18:07 UTC, ionuion
Details
stacktrace (2.57 KB, text/plain)
2014-02-01 13:16 UTC, markee174
Details
stacktrace (3.66 KB, text/plain)
2014-02-10 15:49 UTC, Jiri Prox
Details
stacktrace (3.17 KB, text/plain)
2014-02-17 09:22 UTC, host
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MarPiRK 2013-08-27 11:25:27 UTC
Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b44, Java(TM) SE Runtime Environment, 1.8.0-ea-b102
OS: Linux

User Comments:
athompson: opened java file

athompson: opened java file

zdenek.rod: I clic in spring file with control to class name.

MarPiRK: I opened "Design" in new JFrame.

farnulfo: Inspect source code with all analyzers

athompson: changed java editor tab




Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException: 45401
   at org.objectweb.asm.ClassReader.<init>(ClassReader.java:0)
   at org.objectweb.asm.ClassReader.<init>(ClassReader.java:0)
   at edu.umd.cs.findbugs.asm.FBClassReader.<init>(FBClassReader.java:35)
   at edu.umd.cs.findbugs.classfile.engine.asm.ClassReaderAnalysisEngine.analyze(ClassReaderAnalysisEngine.java:47)
   at edu.umd.cs.findbugs.classfile.engine.asm.ClassReaderAnalysisEngine.analyze(ClassReaderAnalysisEngine.java:34)
   at edu.umd.cs.findbugs.classfile.impl.AnalysisCache.getClassAnalysis(AnalysisCache.java:266)
Comment 1 MarPiRK 2013-08-27 11:25:29 UTC
Created attachment 139299 [details]
stacktrace
Comment 2 ionuion 2013-10-29 18:07:06 UTC
Created attachment 141654 [details]
stacktrace

run Source > Inspect... with FindBugs configuration
Comment 3 Exceptions Reporter 2014-01-16 15:36:48 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=200127
Comment 4 markee174 2014-02-01 13:16:15 UTC
Created attachment 144667 [details]
stacktrace

Attempting to view new Java class
Comment 5 Jiri Kovalsky 2014-02-02 13:32:26 UTC
Petr, can you please fix this issue? It already has 10+ duplicates. Thanks a lot!
Comment 6 Jiri Prox 2014-02-10 15:48:08 UTC
Steps to reproduce: http://services.netbeans.org/synergy/client/app/#/case/3067/suite/551/v/1
Comment 7 Jiri Prox 2014-02-10 15:49:25 UTC
Created attachment 144993 [details]
stacktrace

AIOOBE when running single inspection
Comment 8 Jiri Prox 2014-02-10 16:11:23 UTC
This issue blocks using findbugs analysis 

It seems that findbug does not work with jdk1.8
http://sourceforge.net/p/findbugs/bugs/1228/
Comment 9 swpalmer 2014-02-11 21:17:57 UTC
The underlying FindBugs issue (http://sourceforge.net/p/findbugs/bugs/1228/) is marked as Fixed as of a month ago.
Does that mean we can expect a fix in NB soon as well?
Comment 10 host 2014-02-17 09:22:30 UTC
Created attachment 145291 [details]
stacktrace

I was trying to perform FindBugs inspect on the Java source package of my project.
Comment 11 Petr Cyhelsky 2014-02-24 13:04:26 UTC
*** Bug 237187 has been marked as a duplicate of this bug. ***
Comment 12 Petr Cyhelsky 2014-02-24 13:14:23 UTC
"fixed" in: http://hg.netbeans.org/jet-main/rev/e7b23adf0eee

This is not a real fix, just a workaround for findbugs library's inability to deal with some of 1.8 classfiles - This should be fixed in findbugs 3.0.0 which, alas, isn't released yet. When it is released the findbugs library wrapper needs to be updated and users needing the wunctionality would have to update it via update centrum.
Comment 13 Petr Cyhelsky 2014-02-24 13:19:25 UTC
Marking as P1, because this should be included in 8.0.
Note that the module is not a part of normal distribution - it is downloaded from update center, so if there is a way how to add it to update center later (but before release) than it is not important now and is not a P1.
Comment 14 Petr Cyhelsky 2014-02-24 13:26:04 UTC
*** Bug 233011 has been marked as a duplicate of this bug. ***
Comment 15 Quality Engineering 2014-02-25 01:36:35 UTC
Integrated into 'releases/release80', will be available in build *201402242200* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/e3258ba901bb
User: Petr Cyhelsky <cyhelsky@netbeans.org>
Log: #235089 - workaround for findbugs inability to deal with some 8.0 classfiles
(transplanted from e7b23adf0eee57a32eb2d4b34bd7cf9f30254005)
Comment 16 Quality Engineering 2014-02-25 02:44:47 UTC
Integrated into 'main-silver', will be available in build *201402250001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e7b23adf0eee
User: Petr Cyhelsky <cyhelsky@netbeans.org>
Log: #235089 - workaround for findbugs inability to deal with some 8.0 classfiles


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo