Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 234880 - IllegalArgumentException: bad position: 1
IllegalArgumentException: bad position: 1
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Text
7.4
All All
: P2 with 1 vote (vote)
: 7.4
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT cndreq
: 7.4_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 12:58 UTC by Egor Ushakov
Modified: 2013-09-12 10:30 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.28 KB, text/plain)
2013-08-23 12:58 UTC, Egor Ushakov
Details
stacktrace (1.28 KB, text/plain)
2013-08-26 09:37 UTC, aldobrucale
Details
stacktrace (1.28 KB, text/plain)
2013-08-26 11:43 UTC, Egor Ushakov
Details
stacktrace (1.28 KB, text/plain)
2013-08-26 17:07 UTC, rodrigorsantos
Details
stacktrace (1.28 KB, text/plain)
2013-08-26 17:16 UTC, rodrigorsantos
Details
stacktrace (1.28 KB, text/plain)
2013-08-26 17:25 UTC, rodrigorsantos
Details
stacktrace (1.29 KB, text/plain)
2013-08-26 18:13 UTC, ehsavoie
Details
stacktrace (1.28 KB, text/plain)
2013-08-27 00:01 UTC, David Konecny
Details
stacktrace (1.29 KB, text/plain)
2013-08-27 09:16 UTC, lforet
Details
stacktrace (1.28 KB, text/plain)
2013-08-27 12:52 UTC, host
Details
stacktrace (1.29 KB, text/plain)
2013-08-27 15:07 UTC, lforet
Details
stacktrace (1.28 KB, text/plain)
2013-08-28 12:16 UTC, aldobrucale
Details
stacktrace (1.28 KB, text/plain)
2013-08-28 12:40 UTC, Tomas Mysik
Details
stacktrace (1.28 KB, text/plain)
2013-08-28 14:58 UTC, aldobrucale
Details
stacktrace (1.28 KB, text/plain)
2013-08-29 07:19 UTC, stefan79
Details
stacktrace (1.28 KB, text/plain)
2013-08-29 15:04 UTC, Ondrej Vrabec
Details
stacktrace (1.28 KB, text/plain)
2013-08-29 15:46 UTC, ehsavoie
Details
stacktrace (1.29 KB, text/plain)
2013-08-29 23:34 UTC, rodrigorsantos
Details
stacktrace (1.28 KB, text/plain)
2013-08-30 13:22 UTC, Egor Ushakov
Details
stacktrace (1.29 KB, text/plain)
2013-09-03 07:46 UTC, muellermi
Details
stacktrace (1.28 KB, text/plain)
2013-09-03 07:49 UTC, Ondrej Vrabec
Details
stacktrace (1.28 KB, text/plain)
2013-09-03 07:52 UTC, Ondrej Vrabec
Details
stacktrace (1.29 KB, text/plain)
2013-09-03 09:04 UTC, Ralph Ruijs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2013-08-23 12:58:24 UTC
This issue was reported manually by gorrus.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build 20130823-bf5273f0acf8)
VM: Java HotSpot(TM) Client VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b15
OS: SunOS

User Comments:
gorrus: started two c++ debug session with disassembly view opened




Stacktrace: 
java.lang.IllegalArgumentException: bad position: 1
   at javax.swing.text.JTextComponent.setCaretPosition(JTextComponent.java:1678)
   at org.openide.text.DocumentOpenClose$DocumentLoad$1.run(DocumentOpenClose.java:802)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
   at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
   at java.awt.EventQueue.access$200(EventQueue.java:103)
   at java.awt.EventQueue$3.run(EventQueue.java:694)
Comment 1 Egor Ushakov 2013-08-23 12:58:25 UTC
Created attachment 139136 [details]
stacktrace
Comment 2 aldobrucale 2013-08-26 09:37:11 UTC
Created attachment 139239 [details]
stacktrace

Switched to nb window after changing files externally (hg from commandline)
Comment 3 Egor Ushakov 2013-08-26 11:43:12 UTC
Created attachment 139247 [details]
stacktrace

- open a file
- set carret anywhere
- edit the file in any external editor and save
Comment 4 Egor Ushakov 2013-08-26 11:53:40 UTC
easy steps to reproduce:
- open a file
- set carret anywhere
- edit the file in any external editor, remove all content and save
Then get the exception in the IDE
Comment 5 rodrigorsantos 2013-08-26 17:07:12 UTC
Created attachment 139262 [details]
stacktrace

<Please provide a description of the problem or the steps to reproduce>
Comment 6 rodrigorsantos 2013-08-26 17:16:12 UTC
Created attachment 139263 [details]
stacktrace

<Please provide a description of the problem or the steps to reproduce>
Comment 7 rodrigorsantos 2013-08-26 17:25:12 UTC
Created attachment 139264 [details]
stacktrace

<Please provide a description of the problem or the steps to reproduce>
Comment 8 Exceptions Reporter 2013-08-26 17:25:16 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=203301
Comment 9 ehsavoie 2013-08-26 18:13:12 UTC
Created attachment 139265 [details]
stacktrace

Chaning code from cli with git
Comment 10 David Konecny 2013-08-27 00:01:12 UTC
Created attachment 139276 [details]
stacktrace

external modification of sources
Comment 11 lforet 2013-08-27 09:16:12 UTC
Created attachment 139296 [details]
stacktrace

I was closing a tab, if I well remember.
Comment 12 Exceptions Reporter 2013-08-27 12:46:12 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=203301
Comment 13 host 2013-08-27 12:52:13 UTC
Created attachment 139312 [details]
stacktrace

I have just reverted a file from SVN
Comment 14 lforet 2013-08-27 15:07:12 UTC
Created attachment 139319 [details]
stacktrace

reverting in svn.
Comment 15 Egor Ushakov 2013-08-27 15:15:05 UTC
exceptions number raising rapidly, looks like a recent regression,
this exception happens all the time when using c++ disassembly (where we write file content to the opened file directly)
Comment 16 aldobrucale 2013-08-28 12:16:25 UTC
Created attachment 139368 [details]
stacktrace

external modification
Comment 17 Tomas Mysik 2013-08-28 12:40:25 UTC
Created attachment 139370 [details]
stacktrace

switching browser in php project?
Comment 18 aldobrucale 2013-08-28 14:58:25 UTC
Created attachment 139378 [details]
stacktrace

Search and replace in multiple xml files
Comment 19 stefan79 2013-08-29 07:19:26 UTC
Created attachment 139403 [details]
stacktrace

Selected "Revert Modifications" (CVS) at a java-file.
Comment 20 Ondrej Vrabec 2013-08-29 15:04:26 UTC
Created attachment 139440 [details]
stacktrace

running a mercurial command changing content of open files
Comment 21 Exceptions Reporter 2013-08-29 15:04:38 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=203301
Comment 22 ehsavoie 2013-08-29 15:46:26 UTC
Created attachment 139442 [details]
stacktrace

Waiting for debugging session to start
Comment 23 rodrigorsantos 2013-08-29 23:34:25 UTC
Created attachment 139462 [details]
stacktrace

<Please provide a description of the problem or the steps to reproduce>
Comment 24 Egor Ushakov 2013-08-30 13:22:27 UTC
Created attachment 139494 [details]
stacktrace

reverted a file
Comment 25 muellermi 2013-09-03 07:46:33 UTC
Created attachment 139601 [details]
stacktrace

svn update to older version
Comment 26 Ondrej Vrabec 2013-09-03 07:49:33 UTC
Created attachment 139602 [details]
stacktrace

an open file modified externally by a versioning command, i think the previous caret position was outside of the current file's content (the file was shortened by the git command)
Comment 27 Ondrej Vrabec 2013-09-03 07:52:34 UTC
Created attachment 139603 [details]
stacktrace

the same as before
Comment 28 Ralph Ruijs 2013-09-03 09:04:33 UTC
Created attachment 139612 [details]
stacktrace

Run file ... ?
Comment 29 Miloslav Metelka 2013-09-04 08:28:54 UTC
http://hg.netbeans.org/jet-main/rev/0f56f601975c
Comment 30 Egor Ushakov 2013-09-04 09:11:37 UTC
The fix will be integrated into 7.4, right?
Comment 31 Miloslav Metelka 2013-09-05 11:15:31 UTC
I would like to ask QE for verification. Thanks.


(In reply to Egor Ushakov from comment #30)
> The fix will be integrated into 7.4, right?

Yes, it will be in 7.4.
Comment 32 Jan Lahoda 2013-09-05 14:07:22 UTC
The fix seems fine to me.
Comment 33 Jiri Prox 2013-09-10 13:05:10 UTC
verified in trunk
Comment 34 Tomas Zezula 2013-09-11 16:20:16 UTC
0f56f601975c transplanted to a13cfc173b65
Comment 35 Jiri Prox 2013-09-12 10:30:30 UTC
verified in 

Product Version: NetBeans IDE 7.4 RC1 (Build 201309112301)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b39
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
User directory: C:\Users\jprox\AppData\Roaming\NetBeans\7.4rc1
Cache directory: C:\Users\jprox\AppData\Local\NetBeans\Cache\7.4rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo