Bug 234831 - [74cat]TS_70 Plugin Manager Settings tab behaviour not as expected
[74cat]TS_70 Plugin Manager Settings tab behaviour not as expected
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.4
Macintosh Mac OS X
: P3 (vote)
: 8.0
Assigned To: Jiri Kovalsky
au-issues
: NO74
: 235726 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 04:43 UTC by manikantannaren
Modified: 2013-11-12 10:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (598.44 KB, text/plain)
2013-08-23 04:43 UTC, manikantannaren
Details
<no description> (162.82 KB, image/png)
2013-08-23 04:44 UTC, manikantannaren
Details
<no description> (139.20 KB, image/png)
2013-08-23 04:45 UTC, manikantannaren
Details
<no description> (158.92 KB, image/png)
2013-08-23 04:45 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manikantannaren 2013-08-23 04:43:30 UTC
As per the test suite http://wiki.netbeans.org/TS_70_PluginManager#Test_suite:_Settings_tab
In the step "Check Added Update Center" I should be seeing plugins in the available tab and also the count. I see zero plugins i.e. the available plugins tab is empty

Product Version = NetBeans IDE Dev (Build 201308212300)
Operating System = Mac OS X version 10.8.4 running on x86_64
Java; VM; Vendor = 1.7.0_21
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Comment 1 manikantannaren 2013-08-23 04:43:37 UTC
Created attachment 139096 [details]
IDE log
Comment 2 manikantannaren 2013-08-23 04:44:45 UTC
Created attachment 139097 [details]
<no description>
Comment 3 manikantannaren 2013-08-23 04:45:20 UTC
Created attachment 139098 [details]
<no description>
Comment 4 manikantannaren 2013-08-23 04:45:25 UTC
Created attachment 139099 [details]
<no description>
Comment 5 manikantannaren 2013-08-24 04:28:34 UTC
Works correctly on windows.
Comment 6 unai 2013-08-24 12:46:27 UTC
Works correctly on linux as well
Comment 7 Jiri Rechtacek 2013-08-26 11:42:23 UTC
I can reproduce it on my Mac if follow the steps in spec. In the spec. is missing a step "Check for newest" in Available tab which shows count of plugin in new provider. If you add a UC and uncheck "Check for updates automatically" - the Plugin Manager will check content of the UC only when you invoke Check for newest manually. I think the test spec. should be fixed - Jirko, could you address it to test spec. owner? Thanks
Comment 8 Jiri Rechtacek 2013-09-10 07:14:00 UTC
*** Bug 235726 has been marked as a duplicate of this bug. ***
Comment 9 Jiri Rechtacek 2013-11-12 08:18:51 UTC
Nothing for fixing in NB sources, needed to update test spec. only.
Comment 10 Jiri Kovalsky 2013-11-12 10:02:38 UTC
Test specification updated.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo