Bug 234492 - org.netbeans.Archive.getData: LowPerformance took 3488 ms.
org.netbeans.Archive.getData: LowPerformance took 3488 ms.
Status: RESOLVED DUPLICATE of bug 237592
Product: platform
Classification: Unclassified
Component: Module System
7.4
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 13:01 UTC by dba-daniel
Modified: 2013-11-18 14:01 UTC (History)
41 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (41.40 KB, application/nps)
2013-08-16 13:01 UTC, dba-daniel
Details
nps snapshot (72.19 KB, application/nps)
2013-08-16 22:55 UTC, idclaar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dba-daniel 2013-08-16 13:01:18 UTC
This bug was originally marked as duplicate of bug 232939, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201308152300)
VM: Java HotSpot(TM) Client VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b17
OS: Windows 7

User Comments:
dba-daniel: low performance



Maximum slowness yet reported was 3488 ms, average is 3488
Comment 1 dba-daniel 2013-08-16 13:01:20 UTC
Created attachment 138787 [details]
nps snapshot
Comment 2 idclaar 2013-08-16 22:55:03 UTC
Created attachment 138807 [details]
nps snapshot

After replacing my main library dist (15 projects open) the IDE has been scanning projects for about 20 min.  Typically I end up restarting NB when this happens.  Scanning then completes entirely (without constantly restarting for no apparent reason) within about 10 min.
Comment 3 Jaroslav Tulach 2013-11-18 14:01:18 UTC

*** This bug has been marked as a duplicate of bug 237592 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo