Bug 234435 - Knockout html completion does not offer functions from model
Knockout html completion does not offer functions from model
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: Knockout
7.4
PC Linux
: P3 (vote)
: 7.4
Assigned To: Petr Pisl
Vladimir Riha
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 11:00 UTC by Vladimir Riha
Modified: 2013-08-23 06:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2013-08-15 11:00:09 UTC
Please try this:

- use following HTML and JS files

index.html:
<!doctype html>
<html>
    <head>
    </head>
    <body>
        <div data-bind="text:  "></div>
        <script src="js/knockout-2.1.0.js" type="text/javascript"></script>
        <script src="model.js" type="text/javascript"></script>
    </body>
</html>


model.js:
function SimpleMode() {
    this.log = function() {
        return "logging";
    };
}
ko.applyBindings(new SimpleMode());


- in html page, invoke code completion after 'data-bind="text: | "'

=> log() is not offered.


This is a very recent regression, it works fine in Build 201308072300. I don't want to make it P2 but I think it should be fixed for 7.4, it is basic Knockout usage. 



Product Version: NetBeans IDE Dev (Build 201308150051)
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b39
System: Linux version 3.2.0-48-generic-pae running on i386; UTF-8; en_US (nb)
Comment 1 Vladimir Riha 2013-08-15 11:14:00 UTC
Works also in Build 201308122300, could it be caused by with-branch merge?
Comment 2 Petr Pisl 2013-08-22 21:54:51 UTC
Should work again.
Comment 3 Vladimir Riha 2013-08-23 06:31:01 UTC
Verified, thanks

Product Version: NetBeans IDE Dev (Build 201308222300)
Updates: Updates available
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b39
System: Linux version 3.2.0-48-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo