Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 234204 - Facelets Template Client wizard needs to be more sophisticated
Facelets Template Client wizard needs to be more sophisticated
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
7.3
All All
: P2 with 1 vote (vote)
: 8.0
Assigned To: Martin Fousek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 19:23 UTC by Reza_Rahman
Modified: 2013-10-25 02:11 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reza_Rahman 2013-08-09 19:23:44 UTC
This is with regards to a bit of awkwardness I've seen during the Java EE 7 lab: http://glassfish.java.net/hol/.

The issue is that we have a template with a number of sections like "top", "left", "content" etc. While using the template client wizard, what happens is that the client page inherits all of the overridden template sections. In reality, in all cases in the lab, the clients do not actually need to override "top" and "left" but just "content". As a result, you wind up manually deleting the generated "top" and "left" sections in the client every time.

This actually reveals an area where the wizard really should be more robust. Instead of simply overriding/generating all template sections in the client, the wizard should actually present an option to the user as to which template sections they actually want to override in the client (by default choosing all).
Comment 1 Martin Fousek 2013-08-12 07:09:13 UTC
Thanks Raza, that definitely makes sense. I really like this idea. Targeting to Next for now.
Comment 2 Martin Fousek 2013-10-24 07:55:49 UTC
You are able to select sections to generate in table which was added into the bottom of the Template Client Wizard now.

Implemented in web-main #05e6954da1d7.
Comment 3 Quality Engineering 2013-10-25 02:11:17 UTC
Integrated into 'main-silver', will be available in build *201310250001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/05e6954da1d7
User: Martin Fousek <marfous@netbeans.org>
Log: #234204 - Facelets Template Client wizard needs to be more sophisticated


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo