Bug 234203 - IllegalArgumentException: Invalid org.netbeans.modules.java.j2seplatform for operation ENABLE
IllegalArgumentException: Invalid org.netbeans.modules.java.j2seplatform for ...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Jiri Rechtacek
au-issues
EXCEPTIONS_REPORT
: ERGONOMICS
: 233605 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 18:59 UTC by griloemer
Modified: 2013-08-30 13:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (987 bytes, text/plain)
2013-08-09 18:59 UTC, griloemer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description griloemer 2013-08-09 18:59:32 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b16
OS: Windows 7

User Comments:
GUEST: <record>
  <date>2013-06-04T15:04:59</date>
  <millis>1370347499131</millis>
  <sequence>86</sequence>
  <level>FINEST</level>
  <thread>13</thread>
  <message>CPU INFO</message>
  <param>4</param>
</record>
<record>
  <date>2013-06-04T15:04:59</date>
  <millis>1370347499131</millis>
  <sequence>87</sequence>
  <level>FINEST</level>
  <thread>13</thread>
  <message>SCREEN SIZE</message>
  <param>1600</param>
  <param>900</param>
  <param>1</param>
</record>
<record>
  <date>2013-06-04T15:04:59</date>
  <millis>1370347499131</millis>
  <sequence>88</sequence>
  <level>CONFIG</level>
  <thread>13</thread>
  <message>IDE_STARTUP</message>
</record>
<record>
  <date>2013-06-04T15:05:04</date>
  <millis>1370347504716</millis>
  <sequence>96</sequence>
  <level>INFO</level>
  <thread>25</thread>
  <message>MEMORY</message>
  <param>4207497216</param>
</record>
<record>
  <date>2013-06-04T15:05:12</date>
  <millis>1370347512922</millis>
  <sequence>103</sequence>
  <level>INFO</level>
  <thre




Stacktrace: 
java.lang.IllegalArgumentException: Invalid org.netbeans.modules.java.j2seplatform for operation ENABLE
   at org.netbeans.modules.autoupdate.services.OperationContainerImpl.add(OperationContainerImpl.java:124)
   at org.netbeans.api.autoupdate.OperationContainer.add(OperationContainer.java:292)
   at org.netbeans.api.autoupdate.OperationContainer.add(OperationContainer.java:304)
   at org.netbeans.modules.ide.ergonomics.fod.FindComponentModules.getAllForEnable(FindComponentModules.java:260)
   at org.netbeans.modules.ide.ergonomics.fod.FindComponentModules.findComponentModules(FindComponentModules.java:193)
   at org.netbeans.modules.ide.ergonomics.fod.FindComponentModules.access$000(FindComponentModules.java:71)
Comment 1 griloemer 2013-08-09 18:59:33 UTC
Created attachment 138513 [details]
stacktrace
Comment 2 Jiri Rechtacek 2013-08-12 10:16:45 UTC
http://hg.netbeans.org/core-main/rev/66e72895ff66
Comment 3 Quality Engineering 2013-08-13 02:25:12 UTC
Integrated into 'main-silver', will be available in build *201308122300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/66e72895ff66
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #234203 - IAE: Invalid org.netbeans.modules.java.j2seplatform for operation ENABLE
Comment 4 Jiri Rechtacek 2013-08-30 13:22:00 UTC
*** Bug 233605 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo