Bug 234180 - [Heapwalker] Nashorn compatibility issues in OQL
[Heapwalker] Nashorn compatibility issues in OQL
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.4
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Hurka
issues@profiler
74patch1-verified
: JDK_8, VISUALVM
Depends on:
Blocks: 234511
  Show dependency treegraph
 
Reported: 2013-08-09 12:18 UTC by Tomas Hurka
Modified: 2013-11-21 10:18 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace. (4.11 KB, text/plain)
2013-11-06 16:09 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2013-08-09 12:18:56 UTC
Heapwalker supports OQL (Object Query Language) based on JavaScript. With Nashorn being the JS engine implementation in JDK8, there are many issues in hat.js file.
Comment 1 Tomas Hurka 2013-09-16 14:56:20 UTC
Fixed in profiler-main.

changeset:   263703:7303422b4ab9
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Sep 16 16:47:39 2013 +0200
summary:     bugfix #234180, Nashorn compatibility issues in Heapwalker's OQL feature
Comment 2 Petr Cyhelsky 2013-10-07 13:57:00 UTC
*** Bug 234511 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Skrivanek 2013-11-06 16:08:51 UTC
OQL view in HeapWalker is not initialized in recent build (see attached stack trace).

Product Version: NetBeans IDE Dev (Build 201311060001)
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b56
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b114
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
Comment 4 Jiri Skrivanek 2013-11-06 16:09:25 UTC
Created attachment 141910 [details]
Stack trace.
Comment 5 Tomas Hurka 2013-11-06 17:05:07 UTC
Missing OQL view in HeapWalker is different bug: #236933.
Comment 6 Tomas Hurka 2013-11-13 09:17:57 UTC
Transplanted to release74

changeset:   275826:8947851f1855
branch:      release74
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Sep 16 16:47:39 2013 +0200
summary:     bugfix #234180, Nashorn compatibility issues in Heapwalker's OQL feature
Comment 7 Quality Engineering 2013-11-14 14:33:01 UTC
Integrated into 'releases/release74', will be available in build *201311141216* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/8947851f1855
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #234180, Nashorn compatibility issues in Heapwalker's OQL feature
(transplanted from 7303422b4ab9295015adbcfd013f5299d726c31a)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo