Bug 234159 - org.netbeans.modules.java.project.ProjectProblemsProviders$FileResolver.resolve: LowPerformance took 168953 ms.
org.netbeans.modules.java.project.ProjectProblemsProviders$FileResolver.resol...
Status: RESOLVED DUPLICATE of bug 188001
Product: platform
Classification: Unclassified
Component: JDK Problems
7.3
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 04:08 UTC by Exceptions Reporter
Modified: 2013-12-27 15:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (249.63 KB, application/nps)
2013-08-09 04:08 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-08-09 04:08:32 UTC
Build: NetBeans IDE 7.3.1 (Build 201306052037)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b17
OS: Windows 8

User Comments:
GUEST: ta mtooooo lerdo essa versao. Tava carregando os modulos na inicializacao

GUEST: I opened a project which had old links to some librarys. I clicked "solve links problem" and started to choose the path. Right after that the file chooser hanged for 1-2 minutes



Maximum slowness yet reported was 168953 ms, average is 103373
Comment 1 Exceptions Reporter 2013-08-09 04:08:35 UTC
Created attachment 138474 [details]
nps snapshot
Comment 2 Tomas Zezula 2013-08-19 13:32:31 UTC
All the time spent in Win32ShellFolder2.getIcon() waiting on COMInvoker.
Comment 3 Antonin Nebuzelsky 2013-12-27 15:45:32 UTC

*** This bug has been marked as a duplicate of bug 188001 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo