Bug 233615 - NullPointerException at com.sun.tools.javac.comp.Resolve.checkMethod
NullPointerException at com.sun.tools.javac.comp.Resolve.checkMethod
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 19:28 UTC by theshadow27
Modified: 2015-09-17 11:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.77 KB, text/plain)
2013-07-29 19:28 UTC, theshadow27
Details
stacktrace (3.77 KB, text/plain)
2013-09-06 18:31 UTC, theshadow27
Details
stacktrace (643 bytes, text/plain)
2013-09-06 19:01 UTC, theshadow27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description theshadow27 2013-07-29 19:28:14 UTC
Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b15
OS: Mac OS X

User Comments:
theshadow27: Autocompleted an annonomous abstract class as a method parameter




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.comp.Resolve.checkMethod(Resolve.java:592)
   at com.sun.tools.javac.comp.Attr.checkMethod(Attr.java:3853)
   at com.sun.tools.javac.comp.Attr.checkIdInternal(Attr.java:3654)
   at com.sun.tools.javac.comp.Attr.checkId(Attr.java:3521)
   at com.sun.tools.javac.comp.Attr.visitIdent(Attr.java:3277)
   at com.sun.tools.javac.tree.JCTree$JCIdent.accept(JCTree.java:1993)
Comment 1 theshadow27 2013-07-29 19:28:16 UTC
Created attachment 137962 [details]
stacktrace
Comment 2 theshadow27 2013-09-06 18:31:45 UTC
Created attachment 139772 [details]
stacktrace

Code-completed the name of an anonomous class within a method
Comment 3 theshadow27 2013-09-06 19:01:44 UTC
Created attachment 139775 [details]
stacktrace

More annonomous classes
Comment 4 Martin Balin 2015-09-17 11:27:24 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo