Bug 233551 - Bad Jersey Dependencies added in POM
Bad Jersey Dependencies added in POM
Status: RESOLVED DUPLICATE of bug 232922
Product: javaee
Classification: Unclassified
Component: Maven
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Martin Janicek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 02:30 UTC by Reza_Rahman
Modified: 2013-07-29 07:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reza_Rahman 2013-07-28 02:30:30 UTC
I came across a quirky bug I am having trouble replicating while running the Java EE 7 hands-on-lab: http://glassfish.java.net/hol/.

When people open the starting project (http://glassfish.java.net/hol/movieplex7-starting-template.zip) in NetBeans, for some random folks, NetBeans automatically adds some Jersey dependencies into the POM. It seems this happens because NetBeans does not detect a Jersey application configuration and tries to "fix" the project. In some cases, folks might have accidentally clicked on OK on a dialog without understanding what NetBeans would do. In casual observation, this seems to happen on Macs and Linux distributions, but not on Windows (I am running Windows).

The Jersey dependencies added are completely redundant on GlassFish 4 and more importantly, they fail the deployment unless the POM is manually fixed.

Please help investigate this, it causes quite a bit of problems for the lab.
Comment 1 arungupta 2013-07-28 05:48:52 UTC
Duplicate of https://netbeans.org/bugzilla/show_bug.cgi?id=232922
Comment 2 Martin Janicek 2013-07-29 07:53:18 UTC

*** This bug has been marked as a duplicate of bug 232922 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo