Bug 233477 - CodeCompletion took 6633 ms.
CodeCompletion took 6633 ms.
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 09:58 UTC by Petr Jiricka
Modified: 2013-07-29 15:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (117.50 KB, application/nps)
2013-07-26 09:58 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2013-07-26 09:58:06 UTC
This bug was originally marked as duplicate of bug 221837, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build web-main-11178-on-20130726)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b15
OS: Mac OS X

User Comments:
pjiricka: Code completion in index.html in Oracle JET demo project.



Maximum slowness yet reported was 6633 ms, average is 6633
Comment 1 Petr Jiricka 2013-07-26 09:58:09 UTC
Created attachment 137853 [details]
nps snapshot
Comment 2 Milutin Kristofic 2013-07-29 15:30:11 UTC
I would say it is duplicate of #212851. There is slow picture drawing.

sun.java2d.SunGraphics2D.drawImage()	18.785427	1,098 ms (18.8%)	50.3 ms	76 

The other Code completion is thread is waiting for classloading, that is ok.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo