Bug 233264 - [74cat] [tutorial] Annotation Processor lombok cannot initialize
[74cat] [tutorial] Annotation Processor lombok cannot initialize
Status: RESOLVED DUPLICATE of bug 226165
Product: java
Classification: Unclassified
Component: Source
7.4
PC Windows 8
: P3 (vote)
: 7.4
Assigned To: Jan Lahoda
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 20:18 UTC by skygo
Modified: 2013-07-29 10:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Exception images (25.34 KB, image/png)
2013-07-23 20:20 UTC, skygo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skygo 2013-07-23 20:18:52 UTC
Product Version = NetBeans IDE Dev (Build 201307222300)
Operating System = Windows 8 version 6.2 running on amd64
Java; VM; Vendor = 1.7.0_25
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.25-b01

I tried to follow for reveiw tutorial [1] 

Starting Netbeans, creating java application
linking lombok and configuring processor

At the following step:
Writing an Application Using Lombok Custom Annotations 
 After importing class from lombok a hint appears with and execption I will join on next comment.

 The same workflow using netbeans 7.3.1 is fine.

Regards


[1]https://netbeans.org/kb/docs/java/annotations-lombok.html
Comment 1 skygo 2013-07-23 20:20:29 UTC
Created attachment 137643 [details]
Exception images

Was not able to found Exception in the log I was forced to screenshot. Hope its redeable.
Comment 2 Jan Lahoda 2013-07-24 11:15:01 UTC
Unfortunately, lombok does not support JDK8 javac yet - please see bug #226165 and:
http://code.google.com/p/projectlombok/issues/detail?id=451
Comment 3 skygo 2013-07-24 12:53:21 UTC
Thks a lot for feedback, will notify tutorial owner.
Comment 4 Jan Lahoda 2013-07-29 10:46:42 UTC

*** This bug has been marked as a duplicate of bug 226165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo