Bug 23270 - Finalize DO->Project recognition algorithm and API
Finalize DO->Project recognition algorithm and API
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Windows 3.1/NT
: P1 (vote)
: 3.x
Assigned To: Vitezslav Stejskal
issues@projects
: API
: 26425 (view as bug list)
Depends on: 21313 23285 24067 24095 24097 24360
Blocks: 19955 26618 26740 27144
  Show dependency treegraph
 
Reported: 2002-05-09 09:46 UTC by Pavel Buzek
Modified: 2003-12-11 14:25 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2002-05-09 09:46:02 UTC
Allow the module developer to specify looks for project in project template and use look nodes 
for project components.
Comment 1 Pavel Buzek 2002-07-26 13:53:43 UTC
(looks can in general be used, the part that remains is about recognition of project 
membership)
- implement all heuristics: activated nodes, menu on editor tab
- instances from Lookup covered by new settings framework (ProjectConvertor)
- current project: indication, ProjectSensitiveAction
Comment 2 Pavel Buzek 2002-07-30 13:20:12 UTC
Must-have features for milestone3, have impact on APIs (at least potential).
Comment 3 Pavel Buzek 2002-08-07 11:08:46 UTC
adding the API keyword
Comment 4 Vitezslav Stejskal 2002-08-09 18:41:43 UTC
*** Issue 26425 has been marked as a duplicate of this issue. ***
Comment 5 Vitezslav Stejskal 2002-09-17 17:01:55 UTC
The projects, java and web modules are adapted to use new Looks API.
All looks written by modules and used for visualization of objects
under the project's node can use Lookup of Look.NodeSubstitute passed
to their methods and ask it for Project.class. The Project.find method
shouldn't be used anymore.

Comment 6 Pavel Buzek 2003-07-02 09:34:09 UTC
work done, closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo