Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 232437 - Memory leak - multiple ActiveReferenceQueue daemon threads
Memory leak - multiple ActiveReferenceQueue daemon threads
Status: RESOLVED DUPLICATE of bug 206621
Product: platform
Classification: Unclassified
Component: Lookup
7.4
PC Linux
: P3 (vote)
: 8.0
Assigned To: Jaroslav Tulach
issues@platform
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 11:29 UTC by Petr Cyhelsky
Modified: 2014-07-28 15:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2013-07-09 11:29:57 UTC

    
Comment 1 Petr Cyhelsky 2013-07-09 13:03:50 UTC
please see the heapdump at https://netbeans.org/projects/performance/downloads/download/heapdump_232437.7z there are two instances of org.openide.util.lookup.implspi.ActiveQueue$Daemon

this state was achieved through repeated builds of netbeans modules like Core, Lookup API, etc.
Comment 2 Petr Cyhelsky 2013-07-09 13:21:46 UTC
there is interesting thread dump attached to issue #228424 - there are 19 active reference queue daemons there.maybe it would be worthwile working wit alexander on reproducing this issue...
Comment 3 Jaroslav Tulach 2014-07-28 15:01:42 UTC
The more I think about the issue, the more I believe this has already been resolved. Btw. there is proposal to make this work on JDK without the reflection hacks: https://bugs.openjdk.java.net/browse/JDK-8051843 - support welcomed.

*** This bug has been marked as a duplicate of bug 206621 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo