Bug 232251 - org.netbeans.api.autoupdate.OperationException[ENABLE]: could not add FindBugs Integration[org.netbeans.modules.findbugs/1.27] for activation
org.netbeans.api.autoupdate.OperationException[ENABLE]: could not add FindBug...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Module System
7.4
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 08:35 UTC by MackSix
Modified: 2013-12-18 16:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.60 KB, text/plain)
2013-07-04 08:35 UTC, MackSix
Details
screenshot (63.20 KB, image/png)
2013-07-04 08:55 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2013-07-04 08:35:25 UTC
Build: NetBeans IDE Dev (Build 201307032300)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b16
OS: Windows 7

User Comments:
MackSix: 1. Run Source>>Inspect FindBugs
2. Inspect dialog box says: Additinoal plugins required for the selecte confguration
3. Click Install Button
4. FindBug plugin installed, but message in #2 still shows in Inspect dialog box.
5. Clock Install Button
This error occured.




Stacktrace: 
org.netbeans.api.autoupdate.OperationException[ENABLE]: could not add FindBugs Integration[org.netbeans.modules.findbugs/1.27] for activation
   at org.netbeans.modules.autoupdate.ui.ModuleInstallerSupport.installPlugins(ModuleInstallerSupport.java:221)
   at org.netbeans.modules.autoupdate.ui.api.PluginManager.installSingle(PluginManager.java:175)
   at org.netbeans.modules.analysis.Utils.installMissingPlugins(Utils.java:60)
   at org.netbeans.modules.analysis.RequiredPluginsPanel.installActionPerformed(RequiredPluginsPanel.java:102)
   at org.netbeans.modules.analysis.RequiredPluginsPanel.access$000(RequiredPluginsPanel.java:55)
   at org.netbeans.modules.analysis.RequiredPluginsPanel$1.actionPerformed(RequiredPluginsPanel.java:80)
Comment 1 MackSix 2013-07-04 08:35:27 UTC
Created attachment 136698 [details]
stacktrace
Comment 2 MackSix 2013-07-04 08:55:32 UTC
Created attachment 136700 [details]
screenshot

Tools>>Plugins>>Installed Tab shows FindBugs installed, but I can't activate it.

See screenshot.

Restarting NetBeans activates it.

Installing FindBugs in this way has worked before in this version. I might be able to find reproducible steps to cause this.
Comment 3 Jiri Rechtacek 2013-07-10 13:41:31 UTC
Based on your exception report the FindBugs plugin was installed successfully but module system didn't load it then. It might be a race condition problem while loading newly installed modules on the fly of IDE.

I cannot reproduce it on latest Dev 20130710 build.
Comment 4 Jaroslav Tulach 2013-12-18 16:34:47 UTC
If reproducible, I need logs with
-J-Dorg.netbeans.core.startup.level=FINE
so I know what the system file system thinks about made changes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo