Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 231925 - [74cat] Code completion for named queries is broken if they span multiple lines
[74cat] Code completion for named queries is broken if they span multiple lines
Status: RESOLVED DUPLICATE of bug 212951
Product: javaee
Classification: Unclassified
Component: Persistence
7.3
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Sergey Petrov
issues@javaee
:
: 232571 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 11:59 UTC by misterm
Modified: 2013-07-11 19:54 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2013-06-27 11:59:08 UTC
It is common for named query definitions to be formatted by breaking the query in multiple lines and concatenating strings so they become more readable. However, code completion inside them stops working when it is done.

Product Version = NetBeans IDE Dev (Build 20130626-ac93781533c7)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_07
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.3-b01
Comment 1 Sergey Petrov 2013-06-27 12:05:58 UTC
yes, it's supported withing one literal only.

*** This bug has been marked as a duplicate of bug 212951 ***
Comment 2 Sergey Petrov 2013-07-11 19:54:11 UTC
*** Bug 232571 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo