Bug 231769 - Enterprise application error ACC007
Enterprise application error ACC007
Status: NEW
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.3.1
PC Windows XP
: P3 (vote)
: 7.4
Assigned To: TomasKraus
issues@serverplugins
NB_AND_SDK
: JDK_1.7
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 10:40 UTC by ostermann_bernd
Modified: 2014-02-06 15:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (95.27 KB, text/plain)
2013-06-25 10:41 UTC, ostermann_bernd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ostermann_bernd 2013-06-25 10:40:48 UTC
Product Version = NetBeans IDE 7.3.1 (Build 201306052037)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0_17
Runtime = Java HotSpot(TM) Client VM 23.7-b01
Running an Enterprise Appliation from Netbeans results in the following error message:

org.glassfish.appclient.client.acc.UserError: ACC007: The app client directory C:\Work-BO\Eigene-Programme\java_NetBeans\OopsWeb does not contain a manifest; the app client container cannot process it.  Embedded programs should pass URIs with scheme "jar:" for JAR files and scheme "file:" for directories.
Java Result: 1

When I deploy the EAR file from the admin console I an start it from the console or  from the browser.
I know, thats this is known issue, but I never found a solution.
Comment 1 ostermann_bernd 2013-06-25 10:41:08 UTC
Created attachment 136268 [details]
IDE log
Comment 2 Vince Kraemer 2013-08-05 18:35:11 UTC
can you describe the steps that I would need to take to reproduce this error... step-by-step?
Comment 3 ostermann_bernd 2013-08-06 17:58:20 UTC
I developed an Enterprise Appliation running on Glassfish 3.1.2.2.
This appliation onsists of an app client and ejbs.
It uses the following server ressources:
- java mail session
- javax sql connetion pool
- jdbc ressource

When I run the appliation out of Netbeans then I get the error message ACC007
Comment 4 TomasKraus 2013-08-26 09:36:39 UTC
Could not reproduce on Dev build with GF 3.1.2.2

NetBeans: Deploying on GlassFish 3
    profile mode: false
    debug mode: false
    force redeploy: true
Starting GlassFish 3
GlassFish 3 is running.
In-place deployment at /tmp/mvnapp/target/mvnapp-1.0-SNAPSHOT

INFO: mvn:app:project was successfully deployed in 5,495 milliseconds.
Comment 5 TomasKraus 2013-08-26 12:01:30 UTC
oops, wrong bug#
Comment 6 ostermann_bernd 2014-01-31 17:42:46 UTC
I tested the same EE application with Netbeans 8 Beta and Glassfish 4.0.
When starting this EE app from Netbeans  I got the same error AC007.
I saw that this issue was mentioned the first time about 2010. It seems that no one of the netbeans/glassfish is/was looking for this issue. Very disappointing!
Should I stop bothering you with new Netbeans issues?
Comment 7 ostermann_bernd 2014-02-06 15:52:24 UTC
Solved:
I re-created the EE application in Netbeans 8.0 Beta with platform EE7 (instead of formely EE5 or EE6).
Components:
Jre 1.7.0_51
Glassfish 4.0
Now I could start the application in Netbeans.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo